Does anybody know if QT workson QNX 6.2.1 NC?

I downloaded QT from this site and I untared, so qt is in /usr/X11R6.

I tried to compile the file holamundo.cpp with the next line

#cc -I /usr/X11R6/qt3/include -L/usr/X11R6/qt3/lib -lqt-mt -o holamundo holamundo.cpp

but it return me the next error

/usr/X11R6/lib/libXft.so.2: undefined reference to ‘XRenderQuerySubpixelOrder’

You need to download XFree 86 4.3 from the same place where you downloaded QT3. They work together.

Since XFree86 4.3 installs into /usr/X11R6, it shouldn’t conflict your old versions (most likely in /opt/X11R6). Just make sure you add
-I /usr/X11R6/include -L /usr/X11R6/lib in your compiler options …

Finally I could compile my application, but when I tried to run it, report to me the next erro:

#could not find library libqt-mt.so.3

What can I do, everything seem to works fine, but why my app doesn’t work?

you need to make sure you app can find the shared libraries. Try the following before you run the app:

export LD_LIBRARY_PATH=/usr/X11R6/qt3/lib:/usr/X11R6/lib:$LD_LIBRARY_PATH

noc thanks for your help. Now I can run my application …