I’ve tried installing QNX 6 on my Althon machine, which went painlessly for the most part, until it came to setting up my broadband connection.

I tried 3 different network cards, all of which failed to be detected.

I had a 3com Etherlink III which was detected, but wouldnt let me configure it - it may have been a faulty card, but i only had a mac avaliable at the time as a second machine, so testing was not possible.

Does anybody have a list of network cards guarenteed to work with QNX 6?

Also, is it possible as with BSD Unix to set up a router and DNS server address for a broadband connection?



for ‘supported hardware’ (incl. nics) check this site : … ?network=1

regards HELGE

hi!, i have same problems with qnx 6.2.1 nc

3com Etherlink III (PCI) must be in “PnP Off” mode.
This can be set with driver diskette of 3Com
On Pentium 500 MHz with 512 MB RAM network runnig very fast !!!
even without proxy settings.

I have problem with D-Link DFE530TX (PCI) on Athlon 750 Machine.
After boot in QNX Momentics card is identified propely but can’t connect
to network. Ping to gate does not work. Then I kill io-net process and
load new io-net with promiscuous=1 parameter on the dev-n driver:

io-net -d via-rhine promiscuous=1 -p tcpip

then i starting phlip utility to set IP and Gate values
then everything working ok. I have question:
Where in the booting scripts can i set the parameter described above.
(i don’t want set it every time when i boot qnx)



everything is good now :slight_smile:

Set my etherlink III into non PnP mode, and my network is running stupidly fast!!!

thankyou :slight_smile:

to krisc.44 :
you will have to create/modify the file : /etc/rc.d/rc.local

slay io-net
io-net … etc.
waitfor /dev/socket # i myself don’t have this line im my rc.local file, but i read this in a different thread

then (if you just created it) from terminal :

chmod a+x /etc/rc.d/rc.local