QT3 / qmake or moc not working

I have a nc QNX 6.2.1. and I have installed X free 86 and X photon and QT3 from sourceforge.net (tar archives)
I have set the QT environmentvariables in my .profiles
When I start designer or assistant I get the error message ‘Locales not supported on X server’ and I cannot spawn to help from designer e.g. . Other X-Appplications make no problems, but QT seems a little bit unstable - but this is a minor problem.
I can make the hello world qt-application by hand and it runs perfectly. But if I try to use qmake to generate my makefile, following errormessages are displayed and nothing happens:
unknown symbol: getgrgid
unknown symbol: getpwuid
Could not resolve all symbols
Thanks in advance.


  1. post your .profile and “uname -a”.
  2. what version of qt you downloaded from sourceforge? I believe the 3.2.1 was compiled with QNX 6.2.1PE and 3.1.2 was compiled with QNX 6.2.1 NC.
  3. as for “Locales not supported”, try “export LC_ALL=C” first, or put it in your .profile

Thank You very much

Here is my uname -a
QNX default 6.2.0 2002/05/21-12:17:24edt x86pc x86

Here is my .profile:

default .profile

if test “$(tty)” != “not a tty”; then
echo ‘edit the file .profile if you want to change your environment.’
echo ‘To start the Photon windowing environment, type “ph”.’
export ABLANG=cat $HOME/.ph/.ABLANG

export QMAKESPEC=qws/qnx-rtp-g++

This is my QT version: nqt-x11-free-3.1.2-qnx6-bin.tar.gz

and I will try LC_ALL …

Can it be a X problem. Does QT also run on X-Photon? I have installed xf86-4301-qnx6-bin.tar.gz and xphoton.4.3.src.tar.gz from sourceforce. There were some error(?) messages when untaring xf86. But e.g. ddd and xpdf make are running well ?!


Well, in the original post, you said QNX 6.2.1, but here it shows QNX 6.2.0. I am confused. This could be the root cause of all your problems. If you are sure you used the QNX 6.2.1 CD for the installation, it could be because you haven’t “finished” your installation. Stick your CD back into the drive again, and click the GUI “Installer”, choose to install “QNX Momentics for x86”.

change the LD_LIBRARY_PATH=$QTDIR/lib:$LD_LIBRARY_PATH line to

Good luck!

Thank You!

Oh pardon - it was my fault. Indeed it was the 6.2.0 NC which is installed in a FAT32 guest partition. So this is OK.
I have only GUI problems with QT applications (e.g. designer). The mouse does not work on the right side of the window and sometimes the application and XPhoton are termintaed with ‘fatal IO error’ of the X client (designer) when clicking on frame borders (e.g.). Any idea?

I will try the new .profile and tell You.

Not really OK.
The XPhoton, XFree86 4.3, qt3 were all compiled with QNX 6.2.1. It may or may not work on older versions such as QNX 6.2.0 that you are using.

And what shall I use for my 6.2.0 version ?

You have two options:

  1. If you want to use those pre-compiled xfree/xphoton/qt binaries, you will have to upgrade to QNX 6.2.1.
  2. If you want to stay with QNX 6.2.0, you will have to compile xfree/xphoton/qt from source.

BTW, this below article talks about installing QNX 6.2.1 onto FAT partition if that’s what you wanted:

Thank You

I have already 6.2.1 NC on a CD. On my FAT32 6.2.0 I have already installed so much SW with much time and efforts, so can I put in the 6.2.1 CD and make an upgrade somehow without loosing data or programs ?
The repository shows two entries:
QNX installer for Neutrino
QNX updater for Neutrino

Best regards
:question: :exclamation:

I think you can “upgrade” your 6.2.0 to 6.2.1.
first, install both “QNX installer for Neutrino” and “QNX updater for Neutrino”.
then, restart the installer and you should see “more” stuff on the CD. Choose to install “QNX Momentics for x86”. Reboot the system once that’s done, and “uname -a” should show you are in QNX 6.2.1

Thank You

QNX is great! Updating the QS can be so easy - BUT - now it looks like I am finally doomed… My FAT QNX partition is too small (only 90 MB free and 180 MB required) although there is much space on the FAT partition free (some gigabytes). I think the program is dinit32.exe under windows or so? Can I raise the size of my QNX file somehow without destroying data afterwards from windows or qnx (dinit -S?)?


I have done everthing I can and run qnx 6.2.1 now.
Qt3 still does not work. The problem similar on almost all qt applications:
When starting - e.g. assistant - error messages appear on the console like
QSettings::writeEntry: Invalid key: ’ …
QSettings::readEntry: Invalid key: ’ …

and no settings can be saved (e.g. browser app). Designer does not work at all - also with many error messages on startup.

Now after all I really have no idea what is wrong, for I use the coorect versions and made my entries in the .profile. The set command shows all values correctly.

Who can help?


Last I checked, I worked for me. Something must be wrong on your system. Please post “uname -a”, “env”, “ls -l /lib”, “which -al assistant”, “ls -l /usr/X11R6/qt3/lib”.

also, before you run “assistant”, do a “export DL_DEBUG=1” and it should make your “assistant” print out some more debugs. Post them here…

Thank You very much, hopefully now my problem can be fixed …
Here is what You wanted:

uname -a

QNX default 6.2.1 2003/01/08-14:50:46est x86pc x86


J9PLUGIN_ARGS=-jcl:max -DsystemClassLoader=com.ibm.oti.vm.JxeBootstrapClassLoader -jxeshare:/j9plugin.jxe -debug

ls -l /lib
total 19635
drwxr-xr-x 2 root bin 2048 Apr 21 23:57 .
drwxr-xr-x 4 root root 4096 Apr 22 22:53 …
-rw-rw-r-- 1 root root 836 May 02 2002 crt1.o
-rw-rw-r-- 1 root root 1420 May 02 2002 crtbegin.o
-rw-rw-r-- 1 root root 1308 May 02 2002 crtbeginG.o
-rw-rw-r-- 1 root root 1432 May 02 2002 crtend.o
-rw-rw-r-- 1 root root 1320 May 02 2002 crtendG.o
-rw-rw-r-- 1 root root 633 May 02 2002 crti.o
-rw-rw-r-- 1 root root 657 May 02 2002 crtn.o
drwxr-xr-x 3 root bin 2048 Apr 21 23:57 dll
lrwxrwxrwx 1 root root 20 Apr 25 11:12 libFF-T2K-cache.so → libFF-T2K-cache.so.1
-rwxrwxr-x 1 root root 7671 May 03 2002 libFF-T2K-cache.so.1
lrwxrwxrwx 1 root root 17 Apr 25 11:12 libFF-T2K-fm.so → libFF-T2K-fm.so.1
-rwxrwxr-x 1 root root 13162 May 03 2002 libFF-T2K-fm.so.1
lrwxrwxrwx 1 root root 14 Apr 25 11:12 libFF-T2K.so → libFF-T2K.so.1
-rwxrwxr-x 1 root root 249345 May 03 2002 libFF-T2K.so.1
lrwxrwxrwx 1 root root 14 Apr 25 11:12 libasound.so → libasound.so.2
-rwxrwxr-x 1 root root 122140 May 22 2001 libasound.so.1
-rwxrwxr-x 1 root bin 103570 Jan 18 2003 libasound.so.2
-rw-rw-r-- 1 root root 30976 May 02 2002 libbessel.a
lrwxrwxrwx 1 root root 14 Apr 25 11:12 libbessel.so → libbessel.so.1
-rwxrwxr-x 1 root root 22930 May 02 2002 libbessel.so.1
-rw-rw-r-- 1 root root 32608 May 02 2002 libbesselS.a
lrwxrwxrwx 1 root root 16 Apr 25 11:12 libblkcache.so → libblkcache.so.1
-rwxrwxr-x 1 root root 13065 May 03 2002 libblkcache.so.1
-rw-rw-r-- 1 root root 8832 Jan 18 2003 libblkcacheS.a
-rw-rw-r-- 1 root bin 1423326 Jan 18 2003 libc.a
lrwxrwxrwx 1 root root 9 Apr 25 11:12 libc.so → libc.so.2
-rwxrwxr-x 1 root root 456973 May 22 2001 libc.so.1
-rwxrwxr-x 1 root bin 433397 Jan 18 2003 libc.so.2
-rw-rw-r-- 1 root bin 1532456 Jan 18 2003 libcS.a
lrwxrwxrwx 1 root root 11 Apr 25 11:12 libcam.so → libcam.so.2
-rwxrwxr-x 1 root root 39044 May 22 2001 libcam.so.1
-rwxrwxr-x 1 root root 51797 Jan 18 2003 libcam.so.2
lrwxrwxrwx 1 root root 12 Apr 25 11:12 libcpp.so → libcpp.so.2a
-rw-r–r-- 1 root root 904772 Nov 30 2001 libcpp.so.2
-rwxrwxr-x 1 root bin 624254 Jan 18 2003 libcpp.so.2a
-rw-rw-r-- 1 root root 25396 May 02 2002 libfpemu.a
-rw-rw-r-- 1 root root 27072 Jan 18 2003 libhiddi.a
lrwxrwxrwx 1 root root 13 Apr 25 11:12 libhiddi.so → libhiddi.so.1
-rwxrwxr-x 1 root root 29518 Jan 18 2003 libhiddi.so.1
-rw-rw-r-- 1 root root 28532 Jan 18 2003 libhiddiS.a
-rw-rw-r-- 1 root root 222652 May 02 2002 libm.a
lrwxrwxrwx 1 root root 9 Apr 25 11:12 libm.so → libm.so.2
-rwxrwxr-x 1 root root 97288 May 22 2001 libm.so.1
-rwxrwxr-x 1 root root 82989 May 02 2002 libm.so.2
-rw-rw-r-- 1 root root 236770 May 02 2002 libmS.a
-rwxrwxr-x 1 root root 42812 Jan 18 2002 librpc.so.1
-rw-rw-r-- 1 root bin 202506 Jan 18 2003 libsocket.a
lrwxrwxrwx 1 root root 14 Apr 25 11:12 libsocket.so → libsocket.so.2
-rwxrwxr-x 1 root root 66806 May 22 2001 libsocket.so.1
-rwxrwxr-x 1 root bin 136949 Jan 18 2003 libsocket.so.2
-rw-rw-r-- 1 root bin 216114 Jan 18 2003 libsocketS.a
lrwxrwxrwx 1 root root 20 Apr 25 11:12 libstdc++.a → libstdc++.a.
-rw-rw-r-- 1 root root 2101418 Jan 18 2003 libstdc++.a.
lrwxrwxrwx 1 root root 21 Apr 25 11:12 libstdc++.so → libstdc++.so.
-rwxrwxr-x 1 root root 389197 Jan 18 2003 libstdc++.so.
lrwxrwxrwx 1 root root 13 Apr 25 11:12 libusbdi.so → libusbdi.so.2
-rwxrwxr-x 1 root root 41427 Jan 18 2003 libusbdi.so.2
-rw-rw-r-- 1 root root 940 May 02 2002 mcrt1.o

which -al assistant

-rwxrwxr-x 1 root root 719975 Sep 09 2003 /usr/X11R6/qt3/bin/assistant

ls -l /usr/X11R6/qt3/lib

total 116684
drwxrwxr-x 3 root root 4096 Apr 24 20:37 .
drwxrwxr-x 13 root root 4096 Sep 10 2003 …
-rw-r–r-- 1 root root 63 Feb 24 2003 README
-rw-rw-r-- 1 root root 16095192 May 21 2003 libdesigner.a
-rw-rw-r-- 1 root root 723 May 21 2003 libdesigner.prl
-rw-rw-r-- 1 root root 17723796 Sep 09 2003 libdesignercore.a
-rw-rw-r-- 1 root root 682 Sep 09 2003 libdesignercore.prl
-rw-rw-r-- 1 root root 1458852 Sep 09 2003 libeditor.a
-rw-rw-r-- 1 root root 600 Sep 09 2003 libeditor.prl
-rw-rw-r-- 1 root root 103262 Sep 09 2003 libqassistantclient.a
-rw-rw-r-- 1 root root 611 Sep 09 2003 libqassistantclient.prl
-rw-rw-r-- 1 root root 743 May 21 2003 libqnp.prl
-rw-rw-r-- 1 root root 651 Sep 09 2003 libqt-mt.prl
lrwxrwxrwx 1 root root 17 Apr 24 19:13 libqt-mt.so → libqt-mt.so.3.2.1
lrwxrwxrwx 1 root root 17 Apr 24 19:13 libqt-mt.so.3 → libqt-mt.so.3.2.1
lrwxrwxrwx 1 root root 17 Apr 24 19:09 libqt-mt.so.3.1 → libqt-mt.so.3.1.2
-rwxrwxr-x 1 root root 11697014 May 21 2003 libqt-mt.so.3.1.2
lrwxrwxrwx 1 root root 17 Apr 24 19:13 libqt-mt.so.3.2 → libqt-mt.so.3.2.1
-rwxrwxr-x 1 root root 12181973 Apr 24 19:13 libqt-mt.so.3.2.1
lrwxrwxrwx 1 root root 17 Apr 24 20:37 libqt.so → libqt-mt.so.3.2.1
-rw-rw-r-- 1 root root 550 Sep 09 2003 libqui.prl
lrwxrwxrwx 1 root root 15 Apr 24 19:13 libqui.so → libqui.so.1.0.0
lrwxrwxrwx 1 root root 15 Apr 24 19:13 libqui.so.1 → libqui.so.1.0.0
lrwxrwxrwx 1 root root 15 Apr 24 19:13 libqui.so.1.0 → libqui.so.1.0.0
-rwxrwxr-x 1 root root 457195 Sep 09 2003 libqui.so.1.0.0
drwxrwxr-x 2 root root 4096 Sep 10 2003 pkgconfig

export DL_DEBUG=1


load_object: attempt load of libqt-mt.so.3
load_elf32: loaded lib at addr b8200000(text) b89ebd60(data)
load_object: attempt load of libXrandr.so.2
load_elf32: loaded lib at addr b8c51000(text) b8c53b60(data)
load_object: attempt load of libXext.so.6
load_elf32: loaded lib at addr b8c54000(text) b8c5e400(data)
load_object: attempt load of libX11.so.6
load_elf32: loaded lib at addr b8c5f000(text) b8d2cfe0(data)
load_object: attempt load of libsocket.so.2
load_elf32: loaded lib at addr b8d31000(text) b8d4df80(data)
load_object: attempt load of libm.so.2
load_elf32: loaded lib at addr b8d54000(text) b8d63ee8(data)
load_object: attempt load of libcpp.so.2a
load_elf32: loaded lib at addr b8d65000(text) b8dc7460(data)
load_object: attempt load of libXrender.so.1
load_elf32: loaded lib at addr b8de2000(text) b8de8460(data)
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/Webbrowser’
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/Profile/default/Homepage’
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/PDFApplication’
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/Family’
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/FixedFamily’
QSettings::readNumEntry: Invalid key: ‘/Qt Assistant/3.2.1/Size’
QSettings::readBoolEntry: Invalid key: ‘/Qt Assistant/3.2.1/LinkUnderline’
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/LinkColor’
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/Profile/default/Source’
QSettings::readNumEntry: Invalid key: ‘/Qt Assistant/3.2.1/SideBarPage’
QSettings::readNumEntry: Invalid key: ‘/Qt Assistant/3.2.1/GeometryHeight’
QSettings::readNumEntry: Invalid key: ‘/Qt Assistant/3.2.1/GeometryWidth’
QSettings::readNumEntry: Invalid key: ‘/Qt Assistant/3.2.1/GeometryY’
QSettings::readNumEntry: Invalid key: ‘/Qt Assistant/3.2.1/GeometryX’
QSettings::readBoolEntry: Invalid key: ‘/Qt Assistant/3.2.1/GeometryMaximized’
QSettings::readEntry: Invalid key: ‘/Qt Assistant/3.2.1/MainwindowLayout’
QSettings::readBoolEntry: Invalid key: ‘/Qt Assistant/3.2.1/RebuildDocDB’
QSettings::entryList: Invalid key: /Qt Assistant/3.2.1/Profile
QSettings::entryList: Invalid key: /Qt Assistant/3.2.1/Profile/default
QSettings::readEntry: Invalid key: ‘/Qt Plugins 3.2//usr/X11R6/qt3/plugins/imageformats/libqjpeg.so’
QSettings::writeEntry: Invalid key: ‘/Qt Plugins 3.2//usr/X11R6/qt3/plugins/imageformats/libqjpeg.so’
load_object: attempt load of /usr/X11R6/qt3/plugins/imageformats/libqjpeg.so
load_elf32: loaded lib at addr b8de9000(text) b8e0bb60(data)
Library loaded; type ‘add-sym libqjpeg.so 8060610’ in gdb to load symbols
QSettings::readEntry: Invalid key: ‘/Qt Plugins 3.2//usr/X11R6/qt3/plugins/imageformats/libqmng.so’
QSettings::writeEntry: Invalid key: ‘/Qt Plugins 3.2//usr/X11R6/qt3/plugins/imageformats/libqmng.so’
load_object: attempt load of /usr/X11R6/qt3/plugins/imageformats/libqmng.so
load_elf32: loaded lib at addr b8e0e000(text) b8e69180(data)
Library loaded; type ‘add-sym libqmng.so 8060610’ in gdb to load symbols
QSettings::writeEntry: Invalid key: ‘/Qt Assistant/3.2.1/Profile/default/Titles’
QSettings::writeEntry: Invalid key: ‘/Qt Assistant/3.2.1/Profile/default/DocFiles’
QSettings::writeEntry: Invalid key: ‘/Qt Assistant/3.2.1/Profile/default/IndexPages’
QSettings::writeEntry: Invalid key: ‘/Qt Assistant/3.2.1/Profile/default/DocIcons’
QSettings::writeEntry: Invalid key: ‘/Qt Assistant/3.2.1/Profile/default/ImageDirs’


I don’t have access to a QNX 6.2.1 box right now, and can’t verify everything you posted, but

  1. You have both qt 3.2.1 and 3.1.2 mixed on your system. Please remove them
    rm -rf /usr/X11R6/qt3 and then JUST download 3.1.2 from sf.net/projects/openqnx and install it.

  2. Modify your LD_LIBRARY_PATH in your .profile so that /usr/X11R6/lib is at the top:
    export LD_LIBRARY_PATH=/usr/X11R6/lib:/usr/X11R6/qt3/lib:$LD_LIBRARY_PATH

  3. Modify your PATH in your .profile so that /usr/X11R6/bin is at the top:
    export PATH=/usr/X11R6/bin:/usr/X11R6/qt3/bin:$PATH

This helps a lot - thank You!

I have made only few tests until now and here are the results:

qmake, uic
starting without error messages - showing usage correctly

assistant, designer
starting without error messages and saving configuration correctly

You are right - I tried 3.2.1 first (why not?) and had the problem with the error messages - then I tried 3.1.2 without removing 3.2.1. hoping all needed files are overwritten …
and then vice versa because I still have the problem with the mouse not working proper on the right big window’s sides in qt (I have to squeeze windows). Dragging objects in designer is making traces. Sometimes designer terminates itsself and XPhoton altogether (rare) - I am using XPhoton - not X.
I think this is a problem with X, although xpdf or ddd are absolutely ok. I cannot configure X (X -configure)to autodetect devices - the computer hangs up completely and the configuration file is incomplete.
I have untared xf86-4301-qnx6-bin.tar.gz and xphoton.4.3.src.tar.gz

  • any ideas ???

But now at least I can play a little bit with qt! It is much better now

I agree with you that your remaing qt issues may be related to XPhoton.
As for configuring a real X, you should be able to, as root, run /usr/X11R6/bin/X -configure, as you already know. If it hangs, maybe your graphics card is not supported in that version of X.