About mysql

I have downloaded MySQL 4.0.18 for QNX Neutrino 6.21, my problem is when I tried to intall it, first the instruccions says that I need to create a group named mysql, well I don’t know how can I create a group, because when I create a user I use passwd with the name’s user, but ask me a ID and a group ID …

I didn’t create the group and I have followed the instructions but when I tried to start the deamon, the deamon doesn’t start, the next error is sended “rm: can’t unlink /tmp/mysql.sock no such device or address” …

Another question, how can I put mysql into the path?, because If I want to use it, I have to go to the directory where the program is seat. …

To add a group, edit /etc/group and add something like mysql. Look at the previous lines for formatting.

Check also qnx.com/developers/docs/mome … asswd.html for some additional information.

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH;/path/to/mysql_libs
export PATH=$PATH;/path/to/mysql_bins

Some other usefull links:

Good luck

fmartens thanks for yor help, but I have a question for you, when I added a path in the PATH variable, that path only works if the term where I added the path is open, how can I added a path that works always? …

add it to /etc/profile

Again, thanks for your help, now I have another problem …

I’m trying to compile a program that use the MySQL C API, I compile my
program using:

gcc -I/usr/local/mysql/include -L/usr/local/mysql/lib -lmysqlclient
program -o program.c

I obtain the next errors:

/tmp/ccbOFwBQ.o: In function main': /tmp/ccbOFwBQ.o(.text+0xe): undefined reference to mysql_init’
/tmp/ccbOFwBQ.o(.text+0x34): undefined reference to mysql_real_connect /tmp/ccbOFwBQ.o(.text+0x4c): undefined reference to mysql_error’
/tmp/ccbOFwBQ.o(.text+0x9d): undefined reference to mysql_real_query' /tmp/ccbOFwBQ.o(.text+0xba): undefined reference to mysql_error’
/tmp/ccbOFwBQ.o(.text+0xec): undefined reference to mysql_use_result' /tmp/ccbOFwBQ.o(.text+0x108): undefined reference to mysql_field_count
/tmp/ccbOFwBQ.o(.text+0x120): undefined reference to mysql_fetch_row' /tmp/ccbOFwBQ.o(.text+0x140): undefined reference to mysql_num_fields’
/tmp/ccbOFwBQ.o(.text+0x198): undefined reference to `mysql_close’
collect2: ld returned 1 exit status

what I am doing wrong? or what else I have to do?

Maybe the mysql 4.0.18 you downloaded is no good. Check mysql 3 from qnxzone.com/~fliu/