Setting up Netgear MA401 wireless card

My Wifi struggle continues…

I just got another Wifi card, a Netgear MA401, which I understand is supported by QNX, however when I do a

mount -v -T io-net

It says:

Parsed: mount from [/lib/dll/] mount on [NULL] type [io-net]
mount: Can’t mount / (type io-net)
mount: Possible reason: No such device

Output from ‘pin cis’:

bash-2.05a# /sbin/pin cis
Socket : 1 - Function : 0
Device : Null 0k
Attribute Device : SRAM 1k
Other conditions (att) : MWait
Attribute Device : SRAM 1k
Card tuple version : 5.00
Manufacturer : NETGEAR MA401RA Wireless PC
Name of Product : Card
Add’nl info (lot #) : ISL37300P
Add’nl info (programming): Eval-RevA
Manufacturer ID : 0xb 0x7300
PC Card function : Network LAN Adapter
POST : 0x0
Tuple 0x22 link=2 : 01 07
Tuple 0x22 link=5 : 02 40 42 0f 00
Tuple 0x22 link=5 : 02 80 84 1e 00
Tuple 0x22 link=5 : 02 60 ec 53 00
Tuple 0x22 link=5 : 02 c0 d8 a7 00
Tuple 0x22 link=2 : 03 07
Tuple 0x22 link=8 : 04 06 00 09 5b 54 f6 7f
Tuple 0x22 link=2 : 05 01
Configuration base/st : 0x3e0 0-subtuples
Configuration Index : 0x1 Last Default
Interface : I/O
Feature : 0x19
IO Space : Bus16 0x0-0x3F(6 lines)
IRQ Description : Pulse Level VEND BERR IOCK NMI 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15

The MA401 is listed on, and appears to be recognised by pin, so not sure what’s going wrong…



Hrm. I’ve never ‘mounted’ io-net or anything manually. To get my Orinoco card working, I just ‘io-net -d orinoco []’. I assume it’s the same for Prism chipsets; ‘io-net -d prism network=foobar -p tpcip’ for SSID foobar and full TCP/IP stack. may provide some insight.


Thanks for the tips semen, but unfortunately the same error occurs, which I find a bit odd, as otherwise the card seems to be recognised, if I run devp-pccard on the terminal, I can insert the card, and it displays a desciption in the terminal a second or so after insertion. The MA401 is also listed on as compatible, so I’m a little confused. Is there any debug software for this kind of thing?

Is it possible that the PCMCIA slots are only ‘half’ supported, so it can recognise cards, but not do anything with them? Clutching at straws, I know…



I have the same card and the same problem. Bought it from ebay and put it in my HP OmniBook 4150. Card is recognized by ‘pin cis’, but 'io-net -d prism -p tcpip" shows “No such device”.


Please see my post in D-Link DWL-520+, thanks to a chap at QSS my MA401 is now working, try the script in that post and see if it works.



I tried your script, but it doesn’t work for me. Same error message.

It seems the PCMCIA bus of the Omnibook doesn’t work with QNX. A 3Com Etherlink III, which is supported, too, doesn’t work either. ‘pin’ shows the card and I can configure it with the network tool, but I don’t get a connection.

The cards work under WinXP and Linux on the same notebook, but fail under QNX. :frowning: