problems with keyboard under x-server


I installed QNX 6.2.x on a target pc. Now I can login from a Windows PC via telnet. I start my X-Server under windows (newest version from cygwin) and start “phinx” via telnet on the target.
After some seconds the login window pops up.

I can use the mouse but I can’t use my keyboard to input my login. :frowning:

On the target pc the keyboard work fine.

Can somebody help my to solve the problem?


Can you login to another working unix machine and confirm you have the X-Server software working correctly on Windows?

Actually I have the same (or similar) problem.

I’m running QNX 4.25 + PHINX to access photon remotley from LINUX (SUSE 9.1)
It was hard work, but I managed it to start Photon on my Linux-Display. Everything was fine, untill i opened a shell and tried to use my keyboard, cause no keystrokes have any result (except physical ones on my Keyboard )

If you solved this problen, it would be fine if you let me know the solution.

and here is the solution (for my case):

simply unlock the Numlock and everything works fine. 8)