PCMCIA ACCTON EZ Card 10/100 Model No. SMC8036TX


Fist of all, I’m using QNX 6.2.1 NC (qnxnc621.iso).

I have this little PCMCIA Network card on my laptop and I can’t set it up…
The DID is 1216 and the VID is 1113… it is listed on the supported network cards page:

SMC:SMC 8036TX EZ Card 10/100:0x1113: 0x1216:devn-tulip.so:ARM, MIPS, PPC, X86:CardBus

I tried to start it with the following command:

io-net -dtulip -ptcpip >>>> no success
tried in verbose mode and found with ‘sloginfo -w’ that the driver searches just for some vendor ids and device ids that don’t match mine (my vendor id doesn’t even showup in the list)

then I tried with the ‘rtl’ driver, again no success, in the list of vendor ids my vid showed up but no match for the device id.

also tried the ‘pegasus’ driver… no luck.

I also tried to specify by hand the vid and did, addresses … etc… no success.

any ideas?



Post the “pin” and “pin cis” might also be helpful.

My guess is you will need to find out the ioport and irq from the “pin” output and specify them when you start the io-net.