Noob needs help w/ LOTS of stuff...

Sorry, but I’m real new to all this… Please explain inlittle steps!

  1. I have a partitioned drive. I set my system to run the OS on the active partition. Partition Magic set the QNX partition as the Active partition. However, I can’t figure out ow to set the Windows partition as the active partition so I can boot into Windows. Please help me!

  2. I installed GAIM, GiMP, and BlueBox (Among other programs, but I’m having no difficulty eith them). Whenever I try to run any of these, my Hard drive starts whirring and making lots of racket… but nothing happens. Please help me!!

  3. Is there any way to access files (eg, images, html files, txt docs, etc) that I have stored on a CD? I noticed the music CD Player, but how do I access data CD’s. If there is no way, is there a way I can read files from my windows partition while running QNX? Or save files to the windows partition while running QNX?

Please help me!!

Hi,
Can’t help you with Partition Magic, never used it, the for the programs you mention, these are are all X applications, and maybe you don’t have X installed correctly. Try running one of them from the terminal, just type ‘gimp’ into the Terminal and post what it says.

For the CD, insert CD into the drive, and look inside ‘/fs/’ using either the terminal or the File Manager, and it should appear in there after a few seconds.

Cheers

Garry

Thanks.

In regards to Partition Magic. I don’t want to use it to reset my Windows partition as the Active partition. I was wondering if QNX has some built in method of doing it, or if maybe I could do it from my BIOS boot up (before it loads QNX)

Thanks.

Also, the terminal says:

Gdk-Warning **: locale not supported by Xlib, locale set to C
Gdk-Warning **: cannot set the locale modifiers
Gtk-Warning **: cannot open display: 127.1:0

Also, as a long time fan of the ENTIRE box netwrok, I recently downloaded Pixel32 (the QNX version)…how do I open the Zip file?!

For your GTK problems, looks like it cannot open the X display, make sure you’ve got XFree86 installed, this can be done via the graphical installer. You’ll probably want to restart after doing this, make sure everything is running OK on startup.

For unzipping Pixel32, open up a Terminal and do the following:

cd /home/wjb/Downloads (for wherever the ZIP file is)
unzip pixel32.zip

Okay. I figured the XFree86 stuff… got all that working. Is there anywhere I can download some sort of manual that goes over all these terminal commands?

Thanx.

fdisk /dev/hd0 should allow you to set the boot partition.

Most of the commands are standard UNIX stuff and you can look them up anywhere, but sometimes the QNX versions will have flags not present elsewhere.

You can see a lot of stuff here:

qnx.com/developers/docs/mome … s-all.html

Just post any other problems you have to this site, I think everybody is happy to help a n00b!

Cheers

Garry

Thanks for all your help :smiley: I went into the live support thing and they gave me that same command to reset the drives. Thanks for all your help, and believe me, I’ll ask for help if I need it!

Just something you might want to look at for all your multiboot stuff, is a program call Boot-US … fire it up in Windows and you can create a nice easy multiboot menu system … not as powerful as grub or lilo but easier I think.

Thanks. I just got it set up. Next time I boot up I’ll tell you if it worked.

However, now I have more problems. After installing XFree86, Gaim and the GiMP worked perfectly, but I’m still having problems with Bluefish, or whatever it’s called (the web design program–I’m currently on Windows, so I can’t just go check…sorry), and when I unzipped Pixel32, there was no executable. Here’s the link to Pixel 32 if you need to check it out: pixel32.box.sk

Sorry I’m so stupid! (Though I’m brilliant with Windows!)

For Pixel32, unzip the .zip file and you’ll get a directory called ‘Pixel’ or something like that, inside that there is an executable called ‘pixel’, run that.

basically:

unzip pixel32.zip
cd Pixel
./pixel

Executables on QNX (and UNIX/Linux) don’t need .exe on the end! :slight_smile:

If you register it, let me know how you go, I have contacted the developer to register it, but no response.

For Bluefish, run it on the command line, with the command ‘bluefish’ and post the error messages.

Cheers

Garry

OK… I ran bluefish through the terminal and – lo and behold! – it worked!! Sorry about all the trouble :frowning:

I just remembered, if you installed Bluefish via the software installer, then it will be in your Launch menu, under ‘Development’.

I know. It is. That’s where it doesn’t run from, though… I guess whenever I use it I’ll have to go through the terminal…

Also, anybody know wher I can find a prog that let’s me run Windows programs in QNX? (Similar to Virtual PC) I already like QNX a WHOLE LOT better than Windows (I’ve QNX nearly a week–and it has crashed once!), but I QNX seems to have a lack of programs for the semi-normal person (eg, Photshop, Bryce, Paint Shop Pro, Rhino 3D, AutoCAD, Flash MX '04, – wait… do you sense a motif?)

You may be able to get Bochs to work, but performance running Windows will be bad even on super-fast hardware.

Yes, there is a lack of graphics software, especially vector stuff, this is just down to QNX not being all that popular on the desktop.

Crashed once in a week? I think that’s once too many! Sometimes if I really mess something up, then Photon can freeze, but you can generally still log in remotely.

You cannot run Windows program inside QNX. And yes QNX lacks program because it’s not meant to be used by “semi-normal” persone. Look on the 3rd party CD there is a bunch of goodies there that can get you closer to Windows.

astranetwork.com/~rick/win98.jpg

But as you say the performance was dismal. I did this with a beta version of QNX6.3 - I can’t recall why I think so, but it may need something ni 6.3 to make it work - but it is doable.

It falls under the “How to make your 1.6Ghz P4 act like a 16 Mhz 386” category.

Rick…

Are you beta testers just rubbing it in or what? ;-) I’m always seeing you guys with your 6.3 betas while us mere mortals have to wait! Just kidding… Is that window manager appearance new in 6.3?

Correction, I’ve had QNX nearly a week–and it hasn’t crashed…[/b]