QNX 6.2.1NC - openssh - ipfilter - why me...

Ok, I’m trying to get what I consider to be some “simple” things set up so I can work on some of my projects remotely. I’m trying to get sshd setup to allow tunneling of X11 sessions and it just doesn’t work. I’ve set this up a bunch of times on both Linux and Solaris and yet when I ssh into the QNX system it doesn’t set the DISPLAY variable at all and as a result the tunneling doesn’t happen when I try to run something simple like xterm. I’m tempted at this point to try and compile a newer build of openssh and see if that fixes this problem…anyone else having this issue?

The other issue I’m having is with ipfilter appearing to not keep state on client initiated connections like me sitting at the QNX system and opening voyager or trying to connect to a repository. An initial connection gets made but then communication seems to fall apart. The outgoing TCP/UDP/ICMP rules are set to keep state, yet this doesn’t appear to be working.

And I’ve verified that my firewall issue is not causing the ssh problems I’m having.

Any suggestions would be appreciated.

Well…I couldn’t get the build of openssh on the 3rd party repository to work for tunneling X11 so I tried compiling the latest release with the latest versions of zlib and ssl but I can’t seem to log in with that one. I get permission denied error. SSHD logs to syslog the following:

Account has expired.
Failed none for illegal user from port 65280 ssh2
error: Could not get shadow information for NOUSER
Failed password for illegal user

If I run sshd in debug mode it shows that these errors come up even before the password prompt asks for the password the first time.

Does anyone have the repository version working for tunneling? (openssh-3.7.1p1)

I was able to use openssh from the 3rd party CD.

to tunnel for X:

on local non-QNX box:

xhost +localhost
ssh -R 6000:localhost:6000 myname@qnxservername

once log into qnx box:
export DISPLAY=localhost:0

Not ideal, but works for me.

Ah…That does work, I didn’t even think to try that since I had never had to do it that way before. Thanks, now the X windows stuff works. Hopefully I can figure out phinx now too.