Custom CGI support

Newbee Help,
I am using slinger because of the resource requirements.
System files are scaled back.
The structure of the interest is:
flash0 → web → cgi

I have put Perl in the cgi directory,
the cgi directory is in the library and the executable paths.
When I run ipstats.cgi in a telnet session the CGI script ran properly,
after I added some library files.
When I go to run index.shtml in an HTML browser,
it does not execute the CGI script properly via the SSI.

The following line trips when the next line is executed.

The ipstats.cgi script contain:
exec “cat /proc/ipstats”

boot script settings:
display_msg “** Starting web server (slinger)”
slinger -s -c -e -p 80 &
I am logged in as Root in the telnet session.
Permissions are all 777.
Root owns everything.

Am I missing a Perl library for the html side or what???

Here is what I did. I made a file /tmp/index.shtml and put into it…

Testing 1 2 3 4

And then I ran …

export HTTPD_ROOT_DIR=/tmp
export HTTPD_ROOT_DOC=index.shtml
slinger -p 8081 -s -e -i -d -c

And it worked as I expected. If you are resource constrained I would look at something smaller then perl - perhaps just sh or ruby.

What about the cgi command?

My guess is your perl installation has some issues. Can you try a shell script CGI? or just try cdm’s index.shtml

Sorry, part of the problem was that it did not like 's, a unix thing right?
Also discovered that the /cgi-bin/ thing only works when the text/html header thing is absolutely correct…
I learning…