Setting up Samba on Neutrino


I am attempting to set up Samba (V 2.X from the downloads section) on my Neutrino server.

I have everything configured correctly and my smbd and nmbd daemons start just fine at boot time. I can also view my Samba information from my windows box. But I am completely unable to map any drives from the Windows side of things.

Getting out the Using Samba book I went through the Configuration - Quick Reference chapter.

I am at the point where I run ‘smbclient -L localhost’ on my server to see the list of services offered by my server.

However this command fails outputting the following:

added interface
session setup failed: NT_STATUS_LOGON_FAILURE

The book (and various web sites) say this is because I have an improperly configured guest account (I don’t have one at all). So I tried instead ‘smbclient -L localhost -U username -N’ where username is a user on my server. This displays the same result other than the ‘Password:’ line which means that although I told Samba not to ask for a password and supplied a legit user it still is unable to list services.

Does anyone know what I am doing wrong? I assume I need to add some kind of guest user or change some kind of setting in the smb.conf file to fix this but the book nor the web elaborate on what needs to be done.



With a bit more work I got past the above problem. It seems I needed to create a dummy account of ‘pcguest’ on my QNX server to allow logins to succeed so I got past that point. :slight_smile:

However, for some strange reason even though I have a [homes] section in my smb.conf file I can’t connect to any users home directory. I always get a bad filepath command which looks to mean that Samba is not auto-magically mapping to the users home directory even if I add a -U username on the sbmclient command. So I have that to solve.

I’m now have smbclient successfully connectioning. So I am off to now try and get my Windows box to connect successfully. So far it hasn’t worked using the net use command. I get the login prompt but the username/password is always rejected as being bad even though both are lower case.

Sigh, it’s never as easy as the manuals would have you believe.


The same happen to me with Samba 2.2.7a on FreeBSD, all unix machines can connect but not the ones running windows.

I use the command ‘smbpasswd’ to add (or map) users. All added users must exist in ‘/etc/passwd’. For example:

smbpasswd -a user passwd

it will add the ‘user’ to the samba’s password database (/etc/samba/smbpasswd)
Use ‘smbpasswd -h’ for help.


That was the piece I was missing. Once I did that I was able to map successfully from the Windows side.

I wonder why the Samba book doesn’t mention this as a potential problem or at least mention it could be a problem if you are set up with Security set to USER.