unable to locate fs-pkg!!!!

Okay, I am having a very stressful time over here. I don’t have a lot of experience with bootdrivers and playing around with bios, and I expected QNX to give me a very easy installation. I have installed QNX 6.0 on a windows 98 computer very easily.

However… I wanted to get Momentics 2.6.1 (non commerical version). I downloaded the .iso which virtually took me a while. Burned it on a cd. Now… so far so good. All that comes up is a gui that asks me to use a floppy disk (with “release notes” and “about qnx” links) but other than that… thats it! Where is the install “qnx without any hassle” button? So… I got a floppy disk… and clicked on that big button in the middle.

I rebooted my computer…

says press esc for altboot (I did… and it hangs there)

I rebooted again… it asks again… but i dont do anything… so I waited… and the dots come… good.

but then is says:

/.diskroot file for root not found on any filesystem
unable to locate fs-pkg

and it hangs here!

Here is my situation… I don’t know about command lines… or what prompt to type what to. I never opened up this computer a lot (and it sucks too… its an HP comp propietary piece of crap), very difficult wiring design… err lots of hard to see places. I only got one drive… C:. I got two hard drives “cd writer” and a “dvd.” My computer came with a pre-installed version of windows xp (meaning I don’t have a copy of windows xp cd anywhere!).

What have I done?

I placed whatever files were in the disk’s boot/fs… created my own directory in the C: drive Programfiles/qnx/boot/fs… and copied everything there. I basically saw all the answers and solutions to this problem… and I don’t know anything cause the help was too general. Can someone help me in a step by step procedure? or you can e-mail me at sksallaj@acsu.buffalo.edu and I can give you my sn for aim.

I have read all the threads from people who had this same problem… and not a single solution helped me in any way. There are two reasons why this is might be happening…

1.) qnx doesn’t work too well with two hard drives (cdwriter and dvd) at the same time… but the thing is… QNX SHOULD work well… thats what it was designed to do!

2.) window’s notepad may change some of the inner code of qnx’s files.

You got the wrong expectations.

6.2.1 doesn’t install under Windows. Well you can there’s a post around here somewhere, but it’s a real hack

Altboot is for a backup for QNX os (not sure if there is one on the floppy).
Are you booting from CD or floppy.

That means it didn’t find the CD or couldn’t access it. You could try pressing SPACE ( I think) to get a menu to disable DMA and other feature like P&P that can cause grief.

If XP is install with NTFS instead of FAT, you can’t install without creating a free partition. If you don’t have the CD to reinstall XP that means you must use a tool like PartitionMargic to create an empty partition.

Welcome to the real world (quote from Matrix), what should and what does work is two different thing. I suggest you try the red pill.


thanks for the reply!

I am booting from a floppy.

as for the partition… I am going to free up some space on my computer… and creating a new drive on FAT32.

I do not know how to boot from the cd cause it doesn’t give me that option anywhere.

I will press space once it load… and try out different things too. I’ll post a reply just to update where I am at the moment.


Creating a new drive on FAT32? I don’t understand. You mean to install XP on? What you need is an empty partition, with no type defined. This is were QNX will go. As for the XP partition itself it has no bearing on QNX installtion procedurt. However if it’s NTFS QNX will not be able to access it at run time (sometime useful).

Booting from the CD must be supported by the PC/BIOS. There is no option per se expect in the BIOS, must select CD as boot device and to be used BEFORE HD ;-)

Good luck.

Other option if you have the money, is to use a virtual machine such a VMware or VirtualPC. You loose a little bit of speed but it will work whatever the PC hardware is. No messing around with; my graphics card isn’t supported, my USB mouse doesn’t work, my network card isn’t supported, etc…"

Wow, you are making the help very easy to understand. I am so far in the middle of cleaning out my computer. How much is the suggested space for partition to install QNX? I heard 600MB to 2GB is good. And by FAT32 I think I read your post wrong, I thought it was better to run QNX on FAT32 than it is NFTS.

Also… something happened. When I downloaded a different version of QNX, trying to check it out… it asked me how much space am I willing to give to QNX, I gave it 1GB. However, that version didn’t work, and I uninstalled it. However, it never gave my 1GB back. Know anything about that?

QNX has it’s own filesystem. When you install it, it creates a partition of type 0x79. FAT32’s partition type is 0x12. Every filesystem has it’s own type.

Once qnx is running then it has support for read/write of other filesystems like the fats and ext2 but not officially ntfs.

As for the missing 1GB, it sounds like the installer may have created a file in your windoze partition, it shouldn’t be too hard to find, try looking for qnx*.* filenames.

thanks for the tip…

but here’s a dumb question… how do you install QNX on an empty partition? or does it do it for you? Cause I’m just trying to run it from a floppy disk.

Okay, when I was running partition magic, I created a new partition on an NFTS. It won’t allow me to create a partition without having a filesystem type that it knows about. So I have no idea how to install QNX with its own filetype if partition magic will only give me the options of Fat, Fat32, NTFS, Linux Ext2, Linux Ext3.

It also says: Which OS do you plan to install? QNX is not available on that list (as I expected) so which OS am I supposed to pick from these?:


And the directions said to boot from CD or floppy. I booted from floppy… still gives me the same problems as before. I have no idea how to boot from CD or make it boot before the Harddrive.

Don’t tell partition magic to create a new partition. Just leave it as free space and the qnx installer will find it.

Can you get to the bios screen on your computer? Is so, there should be an option there to select boot order. You need to set it so it boots off the cd, before the hard drive and you should be able to boot the cd. If so, the install program will start and find the free space you just created.


well, I’m certainly in trouble now.

I created a new partition called G:\ and it is in FAT. Well, my stupidity has costed me. Partition has an interesting way of showing what happens if you do this before it actually happens. My G:\ was a logical drive (I read somewhere that it should be primary), and I unhid the drive since the letter wasn’t showing up. (Let’s just say I tried to do two operations at once). Well, when I rebooted my pc, it gives me a horrible error… it wouldn’t load up windows xp. Since I don’t have the CD (HP computer don’t come with a recovery cd), I may have to get it from someone. I know a guy who has WinXp profession (I got the home edition). Also, HP has a partition within the HDD that includes drivers and software (and that can’t be accessed either).

I ran the rescue floppy disks… went to partition magic off the floppy… and checked for errors… and BAM:

Error 1516: Partition improperly dismounted

Apparently there is no drive letter for what used to be my C:\ (all it has a * next to the label HP_PAVILON) and the FAT drive I created earlier (G:) is now my C:\ and the backup drive I created before (which was my F:) has no letter next to it either.

But… one reboot earlier, I finally went into neutrinos but it was in safe mode and couldn’t do something with the cd0 i forgot what it said. I am at a computer at school, and I was thinking of using that WinXp cd to reformat everything. I got a year’s work of stuff going down the drain :frowning:

Just when I thought I was there… something goes wrong. Holy moly. I was working on this for three days with slim to none sleep. I’m burnt.

not that it matters (from the message above)… how would I create free space without doing a partition? I thought a partitioning does that for you. The first thing that pops up is BootMagic (it only sees one OS Winxp). Then it loads up winxp without the floppy. And no… I can’t get to the bios on my screen… so I wouldn’t know anything about setting a cd before the HD. God I’m in trouble.

You shrink an existing partition - but as you mentioned, it probably doesn’t matter much now.


You are learning the hard way -) (which is good I beleive).

When you buy a new HD is empty, it has no partition defined. Somewhere on the disk there is a table that defines how a disk is logicaly configure. If you install XP it will be defaut create one big partition of type NTFS. You can’t create a new partition since there is already one taking up the whole HD. Solution is to use Partition Magic to shrink to current partition size or to reinstall XP and specifiy a smaller partition size. In both cases you’ll end up with a HD with one portion of the HD assigned to a partition of type NTFS and the other partition is unassigned. When QNX installation procedure starts it will detect the unassigned partition (it doesn’t care what’s in the assigned partition, could be XP, Win98, Linux, Solaris, whatever) and offer to install it it.

Hope that helps.

mario, thanks for the help… big time. rick… thanks for that aiding sentence hehe.

Anyways… I really screwed up my partition. I spent a couple hours trying to get it back. Right now… I dont have any OS on my computer. And my C:\ is incorrectly partitioned. I’m not sure of the sizing parameters, or how to grab those numbers, but I when its all done… I will leave 2GB of unallocated space specifically for QNX to find and install itself into. Any unallocated space left over will go into my C:.

I also did what you said Mario, before you sent that message. But in a different way.

What I tried to do is to take any space left over from the C:\ since there is enough of it to run windows xp. I think I read that windows xp needs atleast 600 MB of space… I have 40 GB. So after I partitioned it, created another drive. I formated that drive, so I was left with an unallocated drive.

After that, I found out about resizing… and I slapped my head with an empty palm… so that I left a red mark. Ow.

After reading another thread about this issue, I read an article that noc linked to… on how to install QNX 6.2.1 on a FAT partition. (openqnx.com/Article213.html) So, I converted that unallocated drive entirely to FAT, and followed whatever was on that article. As I mentioned before, I went into safemode for neutrinos.

I got the Windows XP… but it is professional. The computer would not boot from the CD, after formating EVERYTHING. Meaning, I deleted my C:\ and my backup drive as well as my newly partitioned drive, inorder for WinXP to find the space, create its own partition, and install. However, the partition is FUBAR’d. All it says now is:

can’t find bootmagic
press a key to continue:

can’t find OS

hmm… so… I used an old windows 98 start up disk to see if I can create a DOS partition (which I did), and to see if I can boot from the CD (which I can’t).

So… I recommend any one not to buy HP computers… since they don’t have the hardware or the software to aide in critical user mistakes. Right now its at the computer store being fixed.

Just to get the concept right; Unallocated space doesn’t go in c:. C:\ goes into unallocated space

That’s the concept you got wrong. C:\ goes into a partition. So you can’t just simply repartition to make C smaller, because when you do so you actually ampute the C:\

I prefer to use an empty partition for various reason and let the standard QNX6 install procedure use it.

You didn’t have to create a partition, the XP installation procedure creates one for you. With that startup disk you should have been able to access the CD and startup the setup program in d:\i386\winnt.exe.

hi… I got my computer working again. Took a week off from all the frustration. After getting my computer fixed have having to pay a fee for getting back my unmounted drives, I tried my crack at QNX again.

I got an unformated drive D, with no filesystem since I was told that QNX installs its own filesystem.

Here are the facts:
I got windows xp professional, I got 2 gigs of unformated free space on drive D. And I’m trying to install QNX 6.2.1 NC momentics.

Here is what I noticed:
Those who have windows xp face more problems with QNX than those who got windows 9x.

So… I tried to boot from floppy… and the same error occured as my previous post.

However, I can finally boot from my ATAPI cd-rom!


"Unable to mount a cd filesystem as /fs/cd0 on /dev/cd0 (function not implemented)
Unable to mount a cd filesystem as /fs/hd0-dos on /dev/hd0t14 (corrupted filesystem detected)

No QNX 6.1 or greater filesystems available to mount."

I tell ya guys… as much as I want to break free from Microsoft, fate is telling me I won’t acheive that enlightenment. Perhaps I should give up and stick with a 200 Mhz computer with win98 since QNX likes that type of environment.

Why don’t you try linux instead. QNX is not meant to be used as a desktop machine. Given you can’t install it, imagine how it’s going to be when you try to use it…

Oui! Mario, he is using 6.2.1, that’s just the standard message when the IDE controller is not reconised.

Sksallaj: Give 6.3.0 a try now that it’s out. It may reconise your controller. btw, What model is your PC?

don’t I have to pay for 6.3.0 or isn’t it a 30 day evaluation?

I don’t want to play around with partition magic anymore… I already screwed up my computer. Isn’t there any other way of deleting the unformatted D drive. And if I delete it… would there be any way of getting it back? Because I remember the last time I did it with partition magic… and nothing worked.

Also… there is only one time I went into Neutrinos… and that was when I was having it on a FAT filesystem… instead of QNX’s filesystem.

Listen… I dont want to use linux… I have used QNX before. I installed it on slower crappier computers… and I liked it a lot better than the other OS I used. I ain’t gonna open up my computer and start playing around with it cause HP sucks in computer design.

3 weeks… and I still haven’t moved on. the hell with it… where’s my hammer?