Photon doesn't start on QNX 4.25

I’m having a problem starting the Photon v1.14 GUI under qnx 4.25C on a system that worked fine under Photon 1.12 ( Pentium board with a serial mouse and a ISA Graphic board) .
When I’m runnig ph, the system waits for approx. 1 min. ( practically the script is waiting for pwm and pdm to start for 30sec each ) and then it finishes without doing nothing. After that the keyboard is dead but the system is working ( I dittoed it and all the processes are there Photon phfont, pwn, pdm ). And it seems that crttrap is’t launching the video driver too. I’ve tried this after I’ve installed the OS from scratch and the result was the same.

Looking more deeply into the problem I saw that after launching Photn, Input is giving a messagel: Cannot connect to target:0006, although /dev/photon exist ( I’ve tried that with and without mouse,normal and safe ). I’ve updated the software but the same result. Phinstall, which uses a little older version of Photon on the same CD, is working!
After that, I’ve installed again Photon 1.12 and the same system works fine. Please help me!

Post the contents of /etc/config/trap/input. and the output of ‘inputtrap query’.


The output of inputrap query is
Input kbd -R -d/dev/kbd msoft fd -d/dev/ser1
There was no input. file but I created one with inputrap query > input. and the result was the same.
I tried the s/w on a Geode and on a Pentium III board and it still blocks the kbd and displays nothing.

On thinking about this a little more, the problem is just the video driver. The keyboard appears dead because there is no app to respond which has focus at this point in time. Try Ctrl-Alt-Backspace and see if it will exit photon at the point where you think the system is dead.

Also run ‘crttrap clear’ and ‘crttrap trap’ and see what it choses for the video driver.


Thank you Rick! You were right!