update 6.2.0 to 6.2.1 & ata 100 controller card

[color=blue]FIRST : :laughing:
I have Upgraded my old PII 350 and 440 BX mother board with an 40 Go HD that imposed me to use an [color=red]IWILL ATA 100 controller card, as well as if it was an ScSi controller card. Then on my PC My old 4.3 Go with QNX is on the EIDE 66 & the 40 Go (with a 15 Go partition for personnal DATA accessible to any OS) is on the [color=red]IWILL ATA 100 controller card.
[color=blue]SECONDLY : :laughing:
I have installed sucessfully QNX 6.2.0 that fully accepted the [color=red]IWILL ATA 100 controller card & then fully accessed to the 15 Go partition for personnal DATA.
I could put the 4.3 GO disk on the EIDE 66 or on the [color=red]IWILL ATA 100 controller card all worked wery well.
[color=blue]FINALLY: :cry:
When i tried to update from 6.2.0 to 6.2.1 there was no recognizing of the old 6.2.0 so i was obligated to reinstall all.
And now with my new and fresh 6.2.1 i have no access to The 40 Go HD on the [color=red]IWILL ATA 100 controller card.
And when i try to boot from the [color=red]IWILL ATA 100 controller card, the secance boot start but finally failled with that message :
" /. diskroot file for root not found on any filesytem.
Starting with safe mode
Unable to locate fs-pkg ".

:question: :question: :question: :question: :question: :question:

Is there anyway to have access to the 40 Go HD with a missing driver. or shoul i reinstall the 6.2.0 and proced to an update ( But how can i update without a complete install ), maybe whith the QNX Installer.
i think that an update patche would be the welcome or an update procedure include in the launch menu would be the best.
PS : I’m French (or Français), and please be indulgent to my Inglish.

how to upgrade?

while you are in QNX 6.2.0, put the 6.2.1 CD into the drive and click the “Installer” on the right side of the screen, choose to install QNX Momentics 6.2.1 for x86.

On the other hand, since 6.3 is coming out, you might want to wait and try that. There is no upgrade from 6.2.X to 6.3 last I heard, so you will have to re-install everything anyway.

Well tanks a lot for you reply.
Maybe if there is no else solution i think i’ll reinstall 6.2.0 and try to update to 6.2.1
but i wish there is another issue possible.
Waiting this solution, i have get some patch for 6.2.0:
- fs-pkg-patch-nc.qpr
- phlocale-fix.qpr
- shutdown-fix.qpr
And then i tried to install them but each time the dependencies manager asked me an “armle” microprocessor (or somethings like that) and a spécifik librairy too.
So i’m to the same place with still no access to my 40 Go hard drive.
i’m waiting any sugestion.

Well i have soonly install the lates 6.3.0
Graphicaly it’s nice , but i still have no longer any access on my 40 Go HD on the IWILL ATA 100 controller card.
So if any one have some ideas, you are the welcome.