Few problems I'm having...

I posted this on the Unix board over on GameFAQs and was advised to try here. If anymore information is needed, just ask…

1)Is there anywhere I can set QNX to assign a different IRQ and load a driver automatically for my NIC. I have to do it everytime I restart as is…

  1. I’m trying to get GAIM to work so I don’t have to switch back and forth between comps to send IMswhile configuring this thing.
    I get this error message:
    Gtk-WARNING **: cannot open display: 127.1:0
    I installed xPhoton and xfree86.
    After I did so, GAIM loaded once and shut itself down and has been giving me this error when I try to open it now.

  2. I’m trying to setup Apache 1.3.27 on this comp and I’m supposed to connect to my localhost after installing to test it, but whenever I try I get this error:
    “The connection was refused when attempting to contact”

Any help? I apologize if these questions seem asinine, but admittedly, I am still new to Unix…

If you’re using Neutrino 6.2or later, this might help. It’s from the Neutrino User’s Guide, which is available with 6.3:

Device enumeration

Neutrino uses a device enumerator manager process, enum-devices, to
detect all known hardware devices on the system and to start the
appropriate drivers. It’s called by the /etc/rc.d/rc.devices script,
which /etc/system/sysinit invokes.
The enum-devices manager uses a series of configuration files to specify
actions to take when the system detects specific hardware devices. After
it reads the configuration file(s), enum-devices queries its various
enumerators to discover what devices are on the system. It then matches
these devices against the device IDs listed in the configuration files.
If the device matches, the action clauses associated with the device are
executed. You can find the enumerator configuration files in the
/etc/system/enum directory.
Here’s some sample code from a configuration file:

device(pci, ven=2222, dev=1111)
uniq(sernum, devc-ser, 1)
driver(devc-ser8250, “-u$(sernum) $(ioport1),$(irq)” )

This code directs the enumerator to do the following when it detects
device 1111 from vender 2222:

  1. Set sernum to the next unique serial device number, starting at 1.
  2. Start the devc-ser8250 driver with the provided options (the device
    enumerator sets the ioport and irq variables).

To detect new hardware or specify any additional options, you can extend
the enumerator configuration files in the following ways:

  • an oem directory
  • an overrides file
  • a host-specific set of enumeration files

as described below.
The enumerator reads and concatenates the contents of all configuration
files under the chosen directory before it starts processing.
For details on the different command-line options and a description of
the syntax for the configuration files, see enum-devices in the
Utilities Reference.

oem directory

If you’re an OEM, and you’ve written any device drivers, create an oem
directory under /etc/system/enum to contain configuration files for the

overrides file

If you need to set up devices or options that are specific to your
particular system configuration, create an overrides file under
/etc/system/enum. The enumerator includes this file last and adds any
definitions in it to the set that enum-devices works with. If the
overrides file has something that a previously included file also has,
the later definition wins.
For example:

  • If you want to stop a particular device from running, or change how it
    starts, create a /etc/system/enum/overrides file and add a device(…)
    entry for the device:

    device(pci, ven=1234, dev=2000)
    device(pci, ven=1234, dev=2001)
    requires( $(IONET_CMD), )
    uniq(netnum, devn-en, 0)
    mount(-Tio-net /lib/dll/devn-pcnet.so, “/dev/io-net/en$(netnum)”)

    device(pci, ven=1234, dev=2002)
    device(pci, ven=1234, dev=2003)

    The first block of this code specifies to do the following if the
    enumerator detects devices 2000 and 2001 from vendor 1234:

    1.If io-net isn’t running, start it. IONET_CMD is a macro, defined in
    /etc/system/enum/include/net, that specifies the default io-net command
    2.Set netnum to the next unique network interface device number,
    starting at 0.
    3.Mount the PCNET driver into io-net.

    The second block of code tells the enumerator to do nothing if it
    detects devices 2002 or 2003 from vendor 1234.

When you add device entries to prevent devices from being enumerated, 
make sure that there aren't any action clauses after them. Any group of 
actions clauses found after any single or set of device entries is used 
for those devices. Place these device entries at the end of your 
overrides configuration file. 

  • If you want to change the way the enumerator starts TCP/IP, you have to
    override the definition of the basic io-net command that’s defined in
    /etc/systems/enum/include/net. By default, the command is:

    io-net -ptcpip

    If you want to enable IPSec, add this code to your overrides file:

    set(IONET_CMD, io-net -ptcpip ipsec)

Host-specific enumerators

To further customize the enumerators for your system configuration, you
can create a /etc/host_cfg/$HOSTNAME/system/enum directory. If this
directory structure exists, the rc.devices script tells the enumerators
to read configuration files from it instead of from /etc/system/enum.

Even if you have a /etc/host_cfg/$HOSTNAME/system/enum directory, the
enumerator looks for an oem directory and overrides file under

An easy way to set up the directory is to copy the /etc/system/enum
directory (including all its subdirectories) to your /etc/host_cfg/$
HOSTNAME/system directory and then start customizing.

For question 2, sounds like XPhoton isnt running. Type XPhoton & in a term and see if it starts, then try gaim again. Or if you dont mind console IM clients i packaged CenterICQ - aol/msn/yahoo/icq/irc/jabber etc and its really nice. Grab it at hostwork.com/matt/qnx/ .

As for apache, is it the qnx binary of 1.3.27? If it is there are 2 quirks i noticed under 6.2.1. First is that hostname has to be set to localhost, if its set to anything else apache doesnt actually start (even though it posts no error messages) but if you check psin you will notice httpd isnt running. 2nd apache wont start if php is enabled. Comment out any php lines in httpd.conf and start apache. Then once its running uncomment the php lines and restart apache and php will work.

Cheers. :smiley:

Sweet. I got the io-net issue solved (I couldn’t for the life of me see what the issue was since it stopped making me change the IRQ of the NIC. I finally changed the vendor of the card to the actual ven # rather than the name it had it set to).

As par the Apache thing. WHen I run Apachectl it shows httpd running in psin. The Apache I used was the one the software installer found from the online repository, so it should be the same QNX binary you are referring to… I just apparently can’t connect to my loopback address…

And Gaim is now running, but I have a new problem with it. It won’t connect. It doesn’t even look like its trying… You click signon and it basically blinks between the signon dialogue and back to the username/password screen and gives a “Could not connect” error… I read on GAIMs site it could be an issue with AOLs servers not accepting something about my net setup, but the fix they gave was for Linux…

Sorry to be such a bother, but I really appreciate the help.

OK. Got the Apache problem resolved. For some reason it set the port to 8080 rather than 80. Changed it and it worked just fine.

Are you using the latest gaim? 0.76 can be found here qnxzone.com/~kinners/repository/ via package installer. Maybe its an old version you are running, thus the connection problems. Or again i have many console IM clients packaged at the url i posted in my last reply.

Cheers :smiley:

heh… Turns out I’ve got like version .59 or something… Went to install the new version and I get this error.

Package: Gaim 0.76 (x86)
Action: selected to be installed by the operator
Dependency: requires that a package with a “ProvidesLibrary” of libgnutls.so.8 and a “Processor” of x86 also be installed.

Apparently I need something installed prior to installing it. Any ideas as to what that would be?

Sorry to be bothersome… And thanks again.

Along with gaim in that repository you will need to install the gtk2/pango etc packages as gaim 0.76 ( and many newer ported apps ) requires gtk2. After that you should be all set. Its also a good idea to install “every” lib available in the 3rd party repository to avoid most installation issues.

Cheers. :smiley:

I’ve installed virtually every library I could find, but anytime I try and install GTK+ and Pango from kinners, I get similar error messages to what GAIM was giving me.

I installed GAIM with no issues from another place but when I try to run it I get this issue:
“Could not find library libgtk-x11-2.0.so.200”
so I guess I still need something. :confused:

Hmm, the only other thing i can think of is that sometimes the package installer gets a little too picky. Some packages have 2 parts to install. e.g the application itself and development package. Sometimes you have to install the devel package first, then install the application package.

So lets say Foo-0.11-x86-public.qpr is the example. Package installer opens and shows 2 items to install. Foo-0.11 and Foo-0.11-dev. Install dev first, after it completes install foo. Other times if you are sure that those libs are installed you can force the installation rather than abort the install as package installer tells you to do.

Otherwise, yea you might still be missing something. As a last resort if you have libgtk-x11-2.0.so you could symlink that to libgtk-x11-2.0.so.200.

Also what xfree86 version are you using? Gtk2 was built on xfree4.3 and the packages can be found here for that. qnx.wox.org/packages/6.2.x/

Good luck :smiley:

I apparently had 4.2 installed. 4.3 allowed me to install GTK+ and Pango, but the version of GAIM I had was screwed up (gives missing protocol plugin errors) so I’ll have to get the one off Kinners…

Problem now… I need GNUtls, but I have to install libgcrypt to install that. I installed the ‘libgpg-error’ library it requires, but I’m getting errors when trying to ‘make’ it. The output of make is as follows…:

‘# make
make all-recursive
make[1]: Entering directory /libgcrypt-1.2.0' Making all in mpi make[2]: Entering directory /libgcrypt-1.2.0/mpi’
source=‘mpi-add.c’ object=‘mpi-add.lo’ libtool=yes
depfile=’.deps/mpi-add.Plo’ tmpdepfile=’.deps/mpi-add.TPlo’
depmode=gcc /bin/sh …/depcomp
/bin/sh …/libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I… -I…/src -I/usr/local/include -g -O2 -Wall -c -o mpi-add.
lo test -f 'mpi-add.c' || echo './'mpi-add.c
…/libtool[6538]: cannot fork - try again
make[2]: *** [mpi-add.lo] Error 1
make[2]: Leaving directory /libgcrypt-1.2.0/mpi' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory /libgcrypt-1.2.0’
make: *** [all] Error 2’

Any ideas as to what that all alludes to?

No clue what that output eludes to, except i know for a fact that the QNX package of libtool is way outdated (2 years or so old). Libtool will build cleanly out of the tarball should you need it. But you shouldnt have to build libgcrypt anyway, as its also available from the same url that xfree 4.3 was in along with gnutls.

To make installing apps less hasslesome with dependencies you can bookmark any online repository you run across, and installer will connect to all known (bkmarked) repositories in search of the missing deps. This websites links page has numerous repositories and sites containing qnx packages.

Good luck :smiley:

P.S. You could have saved loads of time and frustration by just installing centericq if all you wanted was to simply use IM services ;-)

-_-; I don’t know how I overlooked those files being on that site… I feel like a jackass…

Well, got everything up and running now. Thanks for all the help. I know I could have taken the easier route, but once I start on a problem, I like to see it through.

I think I’ll take a break from QNX for a bit now and get back to working on my Solaris 9 mailserver…

Anyhow, thanks again. :slight_smile: