Boot Problem - Sysinit file damaged


I am new to qnx 4.25 and managed to get a syntax error into the sysinit.1 file causing the boot to hang. The altboot hangs as well. oops! :blush:

I have what I appears to be a bootdisk including the aha8scsi driver image but the corrupt sysinit.1 file is still getting executed. I tried putting a sysinit file onto the floppy but this did not work.

Next, I created a bootdisk per manual but the aha8scsi driver returned no scsi devices found. (during this process, I got a resource in use when trying to mount the floppy - already mounted I presume?)

Next I tried to copy the .boot file from the “aha8scsi” bootdisk to the clean bootdisk but got a can’t unlink file error when I tried to erase the file to make room on the floppy for the new one.

I now know what the altboot is really for!.. Can anyone help?

Thanks in advance.


Boot the PC with the QNX-Boot-Disk and use the command /etc/install.

Followed the installation. Stopped the installing with ESC after starting the
harddisk-driver (Step 1c) !!!

Use the command "prefix -R /=/hd0 ", now you can edit the “sysinit.node” file.

If it´s works, make a copy to a file named “sysinit”, the file will be used by alternate

Thing about the file-format (DOS,QNX2 and QNX4) !

Good luck !


Thanks for the response. Unfortunately, because aha8scsi driver would not recognize the drive we opted for the full disaster recovery plan, but I will keep your response around for the next time I break it!! It would have been a much easier solution!

Another piece of wisdom - you don’t have a disaster recovery plan unless it has been tested and is successful!!!

In the end, it turned out that I had the wrong version of the aha8scsi driver.

Thanks again!