Misc questions about 6.3


I just installed 6.3, and have a few questions:

  1. Is the new Voyager based on Mozilla? It seems to have the same flickery text problem as Mozilla did on 6.2.1.

  2. Is the PDF plugin mentioned in the 6.3 blurb on qnx.com supplied as standard? If so, how does one use it?

  3. USB Mass Storage - Using short words, how can I mount a USB mass storage device?

  4. PhAb no longer wants to import PNGs for icons, they turn up blank (GIFs are fine), is this a deliberate thing?

  5. Have I been really stupid and not spotted the docs for all the above on qnx.com?



6.3 (like every other version) includes HTML documentation. If you’re using self-hosted Neutrino, just start the helpviewer. On other platforms, point a browser at ${QNX_TARGET}/usr/help/product/momentics/bookset.html.

I don’t have answers to most of your questions, but I can point you to the Connecting Hardware chapter of the Neutrino User’s Guide. It has a section on starting USB devices.

Thanks for the info, I looked at the docs, not sure how I missed the but about USB mass storage. Unfortunatly I cannot get any USB device to work, not HID or Mass Storage, and I’ve tried a Sun mouse, Microsoft trackball, Muvo MP3 player, and Dane-Elec SD reader (both mount as mass storage on a Mac).

The funny thing is, all devices are correctly identified by /sbin/usb but I can only get one device identified at any one time. i.e. If I have the Trackball and Muvo plugged in at one time, only the Trackball appears in /sbin/usb. If I start devb-umass, only the Muvo is shown in under /sbin/usb.

/sbin/io-usb -duhci
waitfor /dev/io-usb/io-usb
/sbin/io-hid -duhci

The above is what I use to fire up USB, suffice to say none of the devices work, and no devices appear in /dev/ for the USB card. sloginfo reports:

Jun 15 10:36:03 2 5 0 scsi_interpret_sense: path=0, target=0, lun=0, cam_status=b, scsi_status=0
Jun 15 10:36:04 2 19 900 umass_bulk_csw_cbf: invalid residual 30000000
Jun 15 10:36:04 2 19 900 umass_bulk_reset: path 0, devno 1

repeated several times.

Normally I would suspect that QNX simply did not support my laptop’s USB, but as the devices are recognised, and the trackball lights up on running /sbin/devu-uhci, any ideas what’s going on here?



you don’t want to run both devu-uhci (legacy) and io-usb (now and future).

io-usb -d uhci
waitfor /dev/usb
devb-umass cam pnp

That is how I start it on my workstation with my sandisk multi-format reader.

You also only want to start io-hid and not devu-mouse.

Thanks for the info, my trackball still refuses to work, but there is something showing up in /dev for my SD reader. The Muvo MP3 player does not seem to be recognised as a Mass Storage device, and is not mounted. However, at the risk of sounding stupid (again), how can I access the /dev/hd1 which turns up on connecting the SD reader as an actual filesystem? I tried ‘mount /dev/hd1 /fs/sd’ it does not error, but on trying to go into /fs/sd it reports ‘Corrupted filesystem’.



Try ‘mount -t dos /dev/hd1 /fs/sd’

I tried that before, same problem, fdisk can see the DOS partition on the SD disk, so not sure what’s wrong. Although the Muvo does not show up in /dev at all, which is the device I would really like to access. Is there some list of USB Device Class numbers I can edit?

gman - Once you run io-usb and run the usb utility, does your trackball show up in the list of device? How about the Muvo? What class of device does the Muvo show up as in the output (you might have to do usb -vv).

You should look for a /dev/hd1t12 if it isa dos partitioned device. The only time you mount the device itself is if it is a USB floppy device. You can try running fdisk on /dev/hd1 to see if it is able to find the partition details.

Hi cdm,
Thanks for the ongoing help with this, as requested, output of usb -vv with the Trackball and Muvo plugged in:

USB 0 (UHCI) v1.10, v1.01 DDK, v1.01 HCD
Control, Interrupt, Bulk, Isoch, Low speed

Device Address : 1
Upstream Host Controller : 0
Upstream Device Address : 0
Upstream Port : 0
Upstream Port Speed : Full
Vendor : 0x041e (Creative Technology)
Product : 0x4116 (MuVo^2 (uHDD))
Device Release : r0.01
USB Spec Release : v2.00
Serial Number : 0105255193038C49
Class : 0x00 (Independant per interface)
Max PacketSize0 : 64
Languages : 0x0409 (English)
Configurations : 1
Configuration : 1 (Media)
Attributes : 0xc0 (Self-powered)
Max Power : 440 mA
Interfaces : 1
Interface : 0 / 0
Class : 0x08 (Mass Storage)
Subclass : 0x06 (SCSI)
Protocol : 0x50

USB 1 (UHCI) v1.10, v1.01 DDK, v1.01 HCD
Control, Interrupt, Bulk, Isoch, Low speed

Device Address : 1
Upstream Host Controller : 1
Upstream Device Address : 0
Upstream Port : 0
Upstream Port Speed : Low
Vendor : 0x045e (Microsoft)
Product : 0x0023 (Microsoft Trackball Optical®)
Device Release : r1.21
USB Spec Release : v1.10
Serial Number : N/A
Class : 0x00 (Independant per interface)
Max PacketSize0 : 8
Languages : 0x0409 (English), 0x0809 (English), 0x0c09 (English), 0x1009 (English), 0x1409 (English), 0x1809 (English), 0x1c09 (English), 0x2009 (English), 0x2409 (English), 0x2809 (English), 0x2c09 (English)
Configurations : 1
Configuration : 1
Attributes : 0xa0 (Bus-powered, Remote-wakeup)
Max Power : 100 mA
Interfaces : 1
Interface : 0 / 0
Class : 0x03 (HID)
Subclass : 0x01 (Boot interface)
Protocol : 0x02 (Mouse)

I tried mounting the /dev/hd1t12 but get the same error, oddly, fdisk reports this as FAT32, not DOS, but I tried formatting the SD card to DOS using both a Mac and fdisk on QNX, and get the same error. fdisk is quite able to look at the SD card and reports the size correctly. It can format it too, so I think the USB Mass storage driver is working fine, I’m just trying to access it in the wrong way or something. Incidentally, when I tried to run ‘devb-umass cam pnp’ with the Muvo plugged in, the OS crashed, Caps lock did not work, so I think it was a full OS crash, not just Photon. Maybe this is just ‘one of those things’ or maybe it indicates a problem with my USB, but I thought I would mention it. Although after restart, it did not crash on running devb-umass.

Thanks for the help


Make sure you pass the -tdos option to the mount…(fs-dos is for FAT16, FAT32, VFAT, etc)…

mount -tdos /dev/hd1t12 /dos

That trackball looks like it should work. After you have the usb stack up and running do (in Photon)…
io-hid -d usb
devi-hid mouse

The Muvo should work, I would post to the DDK group on QNX’s site about the failure.

Woohoo! Thanks cdm, the Trackball is working now, looks like the devi-hid line does the trick. I’ll certainly post on the DDK group, see what’s up with the Muvo.

Thanks again.