请问驱动程序的问题!

我有LInux下的设备驱动程序,移植到QNX下可以吗?需要怎么改动才可以呢?请高手指教!谢谢!