xterm (login shell) questions

When in photon, I noticed that if I open an xterm I am unable to ^C out of a command; But if I telnet or ssh into the system, ^C works as I expect - I believe sending a SIGKILL to the foreground process. This may be an xterm configuration thing, but I’m not sure. Anyone know?

Also: Whether I log in through telnet or ssh or am in photon, a TERM=xterm setting means I can’t use the backspace key. I remember being able to change this behavior, but I can’t remember specifically what it was.

My final question deals with xterm’s in photon: I noticed, by default, it doesn’t include a scrollbar. I can turn that on and off manually, of course, but I’d much prefer to have it on by default. Anyone know how to do that?

Many thanks!



I found that “-leftbar -sb” on the xterm cmdline creates the scrollbar I need.

As for the backspace key: I described it wrong. Basically my HOME/END keys
only produce a beep, not the anticipated action. I imagine this could be cahnged
by calling stty, but I’m not sure of the params with QNX. Anyone?

xterm options (like scroll bar, Backspace key, etc) can be set in the resource file (/etc/X11/app-defaults/XTerm for all users on the system, or $HOME/.Xresources for one user). Check the generic xterm document (google) for details.

Last I use xterm, Ctrl-C worked fine. I am not sure if your problem relates to an older version of XFree86 or the fact that you are using it via XPhoton. You could try the new XFree86 4.3 from sf.net/projects/openqnx or you could just the rxvt (a replacement of xterm).