Embedded Photon

I am building an embedded photon app but I am having trouble with phfont loading correctly.
I am running v6.3, on a PC104/Geode/CF card.
All runs ok - Disk, Network, serial port etc, but I cannot get photon to start because the phfont fails.
This is the output of phfont when DL_DEBUG=1


load_object: attempt load of libfont.so.1
load_elf32: loaded lib at addr b8200000(text) b820a660(data)
dlop# en(“phfont.so”,3586)
load_object: attempt load of phfont.so
load_elf32: loaded lib at addr b820b000(text) b822a2e0(data)
Library loaded; type ‘add-sym phfont.so 804876c’ in gdb to load symbols
load_object: attempt load of libfontharnessutils.so.1
load_elf32: loaded lib at addr b822f000(text) b8233860(data)
Fatal error - check sloginfo.
Unable to open font DLL: No such file or directory

The output of sloginfo:


Time Sev Major Minor Args
Jul 21 13:00:34 1 8 0 phfont_init
Jul 21 13:00:34 1 8 0 phfontXX started OK
Jul 21 13:00:34 1 8 0 FatalError
Jul 21 13:00:34 1 8 0 No render engines loaded. io-font
Jul 21 13:00:34 1 8 0 Unable to launch Photon Font Server main.

Any ideas?
What’s missing?


Add /lib/dll to the procnto LD_LIBRARY_PATH in your boot image.

Thanks for the reply,

I’ve checked that, the path is:

However, I would have expected the failure to report a missing library if it could not be found. For example if I remove one of the libraries it will say that is failed to load xxx.so etc.
With this error it does not state the DLL file that it was looking for.



  • /lib/dll/font/FCcore.so
  • /lib/dll/font/PHFcore.so
  • /lib/dll/font/ttfFFcore.so
    exist ?

does /usr/photon/config/crtc-settings exist ?

These are required too.


PS: I was pointing to the LD_LIBRARY_PATH in the bootimage just before procnto is called.

Is io-graphics running when you are trying to start phfont? The way I read the error message is it tries to connect to the render engine (the graphics driver) and fails.


Freddy - thanks for the ideas, it’s working now.
I think it was the /usr/photon/config/crtc-settings file.
It was on the image but in /etc/system/config.
Thanks for your help. :smiley:

Rick - I started with io-graphics but that starts phfont and I had the same problem. So I was focussing on getting phfont going. Thanks anyway. Ian


You get the same error when /lib/dll is not in the procnto LD_LIBRARY_PATH.


I’ve got a problem with phfont.
All photon’s servers are running ok when the system boot, i’ve got the good font for all applications launched in the OS image(pterm, phmenu,…) or by NFS, but only phfont’s process disappeard after booting. If i type “pidin arg” its process isn’t running, and i read in the sloginfo :

phfontXX started OK
phfontXX started OK
could not open config file “” : no such file or directory
fatal error
unable to start error thread
unable to set up ressource manager 08 phfont.so
received terminate request, existing - EOK

=> which file does it need more, i’ve added all the shared library necessary for photon and the font_repository directory in the OS image, i think i nothing forget ?
LD_PHOTON_LIBRARY contains /lib/dll:/lib:/usr/lib:/usr/lib/dll:/usr/photon/lib:/usr/photon/lib/dll:/usr/photon/font
if somebody has met the same error message ?

I had similar problems and this is what I did. Make sure you have declared your PATH and LD_PHOTON_LIBRARY path in your build file in
the same line with space seperating the two statement. Because If you declare these two path in two seperate line in the build file then for some reason _CS_LIBPATH is not set correctly.
[virtual=x86,bios +compress] .bootstrap = {
PATH=/proc/boot:/bin:/sbin:/usr/bin:/usr/sbin LD_LIBRARY_PATH=/proc/boot:/lib:/lib/dll:/usr/lib:/usr/dll:/usr/photon/lib:/usr/photon/dll HOME=/

Hope this works.

thank you very much jinma
i’ll try this for the future next OS image…;

Can anybody help me ?
I am troubling with a problem in booting into Photon. I made an image with the example in helpviewer , " Photon in Embedded Systems" , and I modified the io-graphics so that it suit me.
But it looks like this : “Hit Esc to altboot…” when it starts up, it stops there!
I don’t know what’s the matter with that, maybe I should give up that .
Can anybody email me a buidfile and tell me the precedure step by step ? I’ll greatly appreciate your help.
my email address: dive_dmm@hotmail.com

I have similar problems. I defined LD_LIBRARY_PATH=/proc/boot:/lib:/lib/dll:/usr/lib:/usr/dll:/usr/photon/lib:/usr/photon/dll in my boot image, but when I can’t to start phfont.

Embedded system contains this binary and library:

/bin: ksh, on, pidin, sh, sin, sloginfo, waitfor
/lib: libFF-T2K-fm.so.1, libFF-T2K.so.2, libblcashe.so.2, libc.so, libc.so.2, libfont.so.1, libfontutils.so, libfontutils.so.1, libm.so.2
/lib/dll: devg-vmware.so, phfont.so
/usr/bin: sleep
/usr/lib: libAp.so.3, libdisputil.so.2, libffb.so.2, libgri.so.2, libph.so.3, libphexlib.so.3, libphrender.so.2
/usr/photon/bin: Photon, devi-hirun, fontsleuth, getconf, io-graphics, phfont, pterm, pwm, setconf
/usr/sbin: slogger

Embedded system also contains /etc/system/config/crtc-settings

What I’m missing?