Commercial license expired, cannot build with PhAb

Hi there,
Unfortunately the dreaded day has arrived and my commercial license of 6.3 has expired. However, I now cannot build with PhAb, as it wants a commercial license key. So how can I get it build in a non-commerical mode? I tried choosing a gcc target in PhAb, but it still uses qcc and still asks for a license key.

What have I missed?



Good thing I was out of the country when 6.3 was first released. I couldn’t download until later on, so my license is still valid :slight_smile:
Have you tried to reset your PC clock?

Hi noc, I don’t really want to break the rules on this, I just thought it was the case that after the 30 days are up, it reverts to the 6.2.1 NC style license, so you could still use PhAb with gcc etc. Is that not the deal? Is it a matter of paying up or not developing on QNX at all?

Enter in the same License Key you entered when you first installed 6.3.0, the one that is emailed to you after you downloaded the evaluation.

The problem is (I assume) that the makefile created by PhAB is using qcc - which no longer works after the license expires. You need to change the makefiles to use gcc which should still work.


evanh: I tried that, and it says the license is expired and to contact QNX (and give them a cheque for $8000, no doubt).

rick: I tried this, and after changing around a few flags this worked, thanks.

Is using QNX like this above board (legally), or does QNX want payment for non-commercial use now?

hmm … has worked fine for me multiple times.

Our license didn’t work after the 30 day limit either. We had a disk crash and had to reload. Entering the license brought up the “expired license” message. Had to resort to changing the date in the bios.

As far as I know, this is completely legit. As long as it is for non-commerical use.

Of course I can’t speak for QSS, but that is clearly my understanding.


opps, looks like I spoke too soon. I’ve joined the club.

That’s cause you were using the beta license which expired July 30th. (as I discovered on a couple machines). Fortunately I have a real license to replace them with. :slight_smile:

If you look at the file /etc/qnx/license/licences (path is from memory), it is a text file which includes the expiry date - in case you were interested. :slight_smile:


heh, absolutely correct. Two licences are there. the install one plus the beta one. I must have been experimenting… ;)

Just a quick one, can someone tell me where I need to change qcc to gcc in a project created under 6.3? My projects created under 6.2.1 were changed quite easily, but those created under 6.3 have a very different structure/directory layout and I can’t find what I need to change.



Hi Garry, try this proceeding:

  • creat a project under 6.3
  • save an close this project
  • copy files abapp.dfn and abapp.wsp from any project under 6.2.1
    to a new project under 6.3.0
  • reopen a project , select platform gcc and modify Makefile


Hi Ernesto,
I’m afraid that does not work for me, when I open the new project after copying the abapp.* files PhAB complains about certain modules not existing. The modules are from the 6.2.1 project.

I’m wondering if it’s OK just to copy a whole 6.2.1 project, rename it to be my new project and just hack out all the stuff I don’t want? This might be pretty messy but I think a project created under 6.3 is obfuscated on purpose to stop them being modified to use gcc.

Just a followup, I tried copying a 6.2.1 project and after ripping out all the bits I did not need and modifying the Makefile to reflect the new name of the program, it seems OK.

question from germany, just to avoid unnessesary work :
setting the bios clock ‘forward’, means telling it it’s 2004, august 2nd, when my bathroom calendar (printed version) says it’s 2004, august 8th.
right ? (but not logical in german terms)
thanks for brushing up my english !

Why would you assume that? It wasn’t obfuscated, it was changed to be compatible with the IDE. Importing old PhAB project’s into the IDE was a royal PITA before. Now they are the same.

Not sure exactly what you’d have to do to make it use gcc instead of qcc, but since it’s now based on the “common makefile” system, you probably can figure something out by reading “Conventions for Makefiles and Directories” in the programmers guide.

Funny to me that should be backward nor forward.

I just found the Makefiles to be quite complicated, and not as obvious as to what is going on compared to 6.2.1 projects.

I’m just using a new 6.2.1 project to make all 6.3 projects and that’s working OK now. I’d like to be able to do it properly, but it’s no big deal.