Troubleshoot this for me...

Every time I restart my QNX box, as soon as I launch Photon, the keyboard stops working. The NumLock key won’t work, and I’m unable to type anything. So, I have to restart again. But, once I do the second restart, it always works. Any ideas?

Describe for me the two restarts:

  1. “Every time I restart my QNX box”
  2. “So, I have to restart again”

Are the two different? ie. in case 2. you can’t do a controlled shutdown (as your keyboard is no longer responding) so do you do a warm reset?
And is 1. a cold-boot (power-up?)

Number one is a restart from the QNX login prompt. It doesn’t seem to matter if I do a shutdown -f or just hit the reset button on my box. My keyboard locks up after entering “ph” and loading Photon. I can move my mouse and click icons, but even when I go to the QNX button and do a “Shutdown”, the keyboard is still non-responsive once I get back to the QNX prompt. I have to then hit the reset button on my box to reboot.

What version QNX are you running?

I’m not an expert in the Photon input architecture, but devi-hirun seems to be involved somehow. There are several threads in the QNX public newsgroups on these topics. For example, there is a thread in q.p.d.input starting on 9/10/2001 that describes problems with devi-hirun. There may be other posts on the newsgroup that describe keyboard / Photon problems, I did not perform an exhaustive search.

Have you tried the “always boot into Photon” option? (ie. remove the file /etc/system/config/nophoton)?

  • Tony

I’m running QNX 4.25. I do not want to boot directly into Photon, which is why I’m not using that option.

Try to add -R option to Input in trap/input.X

This is what was in input.1. What should I change?:

kbd -R fd -d/dev/kbd ps2 -r kb -2

Try removing the -R then ;-) Read the doc of Input, maybe I’m confusing -R with -r, the idea is to prevent or enable reset of the keyboard when Input starts.