Help with cron at boot


thanks to all for your help with other questions,
here’s a new one.

I’m setting QNX system as a file server and automatic backup,
I’ve installed samba on it and mapped two ways QNX and Windows systems.
I’ve manually prepared a cron job to make copy of windows share every 20 minutes.

BUT I got problem doing it automatically,

I tried to put cron on rc.local

inetd &
/opt/sbin/smbd -D
/opt/sbin/nmbd -D
fs-cifs //PC_NAME:PC_IP:/WINSHARE /qnxshare USER PASSW
/opt/sbin/httpd &

/usr/sbin/cron &

cron job is:
1,21,41 * * * * cp -RN /qnxshare /backup

I got a mess,
after reboot my samba functions where lost,
I could map Win share but Windows cannot see QNX anymore,
also cutting cron line and rebooing leave me with the problem.
I had to reinstall all

I found a document
where they say QNX cron doesn’t support number lists (1,21,41),
could it be the problem ?
but why it messed up also samba ?
is there any other place where can I start cron at boot ?

Thanks in advance,

QNX’s cron works fine with number lists and starting cron in the rc.local is fine. I am not sure about the samba stuff (I avoid windows shares with a passion).


Thanks Rick,

I suspected so because launched manually the cron job is working fine,
part of the question is answered.

Could you help with the rest.
If I install the system, just leaving out the cron line from rc.local let all work fine,
from the time I put the line there I loose all samba functions (mapping the QNX server from Windows).



problem solved,
but I would like an answer from support.

Here’s what I changed:

  1. changed cron job from 1,21,41 … to 19,39,59 (may be cron job started before resources where available)
  2. changed cron line position in rc.local, I’ve putted it before fs-cifs (may be fs-cifs, that’s not a background job, gave problem to cron)

so one of the two, or both solved my problem,
but why the thing messed (broked) samba ?
It shouldn’t go that way.

Can I have an answer how to fix samba in this case ?
It’s not the best solution to reinstall all.
Anyway I installed the package that come from QNX supported 3rd party online package.

Thanks in advance,

Certainly you would have problems with cron (or at least your copy) if it occurs before the file system is up and running. You can certainly waitfor the mount to succeed before you run the cron - or better yet, write the action in the cron so it properly handles the fact that the file system may not be mounted.

On a couple other points, you said:

This is a community supported site - this is not any sort of official QSS support channel - this means you will get an answer if someone knows the answer and they decide to answer it - nothing more, nothing less. ;-)

You also mentioned:

The 3rd party CD is exactly that - and it is explicitly NOT supported by QSS. Certainly it involved a lot of work by some QSS employees, as well as members of the community but if something on the CD doesn’t work, or work the way you expected, it is your tough luck.

Hopefully someone who uses samba will see your problems and give you some ideas how to solve them.


Hi Rick,

I apologize for my message,
you understood exactly what I meant,
I supposed this site was direct or some extension of QSSL.

Following your last quote the big “?” is why such a thing messed the system (I can replicate it if needed)

Anyway I took all the bad and all the good,
let’s say that in three days, on a completely new system (far from what I was used to)
I got a working enviroenment that does all I asked at first,
of course more you have more you would…

Thanks again Rick,