Need help with VNC on QNX 6.21

I managed to get it running (after a load of trouble), but now I have a couple of more questions:

  1. How do I make it so that it runs Photon on the VNC viewer. I’ve tried issuing the command within it and setting it into the startup file, but it doesn’t really work (likely due to the next problem)

  2. Any applications I run won’t run from the remote desktop run on display 0 instead thus keeping me from seeing them through VNCviewer. How do I solve this.

Any help would be appreciated.

  1. you will have to use phinx (Photon in X) so that you can run Photon applications inside the VNC X server. VNC viewer will then be able to “see” it.

  2. X application or Photon application? for X app, it should just work, but for Photon app, you will need the phinx kludge.

phinx doesn’t seem to be working for me…

I run the following command in TWM: “phinx -display localhost:1” and it acts like its done something, but it didn’t.
I’m not sure if that’s the proper formatfor starting phinx, but any other variation gets me a “Could not connect to 127.1” error (and half the time that syntax does too)…

I realize I may seem very n00bish here, but I haven’t run into many people mentioning how to use VNC with QNX online (lots of people know how to make it use kde or gnome, but that’s not very helpful…)

Check my post in this thread regarding phinx. Essentially, you can just type “phx” script to bring phinx up. Since phinx relies on phrelay, you will need to make sure the following lines are present and uncommented in /etc/inetd.conf :
phrelay stream tcp nowait root /usr/bin/phrelay phrelay -x
Of course, you have to make sure “inetd” is running.