Making PtWindow appear on all backgrounds

I’ve got a PtWindow which has Ph_WM_STATE_ISBACKDROP applied to it, this puts it very nicely onto the backdrop, as intended. But unlike the standard wallpaper, it only applies to the current workspace. This means that when I use World view on the shelf to move to a different workspace, my window does not display.

Is there a way to make it apply to all workspaces like the standard wallpaper?



Hey Garry,

You have to indicates that your window must be displayed in all workspace … don’t have my code here with me to check how
to do it … but I think there is a Pt/Ph* function for that …

I’ll look in my code tonight and try to post which function is it.


Hi jlv,
Just had a look on, is it this flag: Ph_WM_CONSWITCH?

If it is, can you post a quick 1 line example of how to use it in conjunction with Pt_ARG_WINDOW_MANAGED_FLAGS? I’m using the flags for something else, and it’s just not working, so I guess I’m doing something wrong. :blush:



Hi Garry,

Sorry, I totaly forgot last night … However, I don’t think Ph_WM_CONSWITCH do the trick …

Let me see if I can look at some of code from work …


Actually, I was wrong … you do have to use Ph_WM_CONSWITCH … Here’s what I do when I want a
window to be visible on all workspace :


hope this’ll help.


Thanks jean-louis, that works great.


Glad I could help :slight_smile: