Dev.par bug in QNX 4.25D ?

Hello,

After QNX 4.25 C to D upgrade from June 2000 CD, Dev.par now terminates with
floating point exception at 0005:000007AC

I tried changing BIOS settings without any result, and I see nothing about in
the documentation. But in patch D release it is said about Dev32.par changes :
" - Fixed timing loop so that it’s better on newer machines"

sin info says :

CPU: 686/687 Machine: PCI Speed: 2849

The CPU is an Athlon 750 MHz running on a ASUS K7V motherboard.

Is this a known bug ?
Is there any solution ?

Thanks for some help

Arnaud


Arnaud Delmas e-mail: arnaud.delmas@cea.fr
CEA - CEREM
Centre de Saclay, STA/LMS Bat. 611
F-91191 GIF SUR YVETTE CEDEX, FRANCE
Ph.: +33 1 69 08 48 96 Fax: +33 1 69 08 75 97

This is fix in a Alpha version, I’m not sure if it’s been made
available, check on quics /updates/qnx42/… in a Alpha directory

“Arnaud Delmas” <arnaud.delmas@cea.fr> wrote in message
news:8oient$mvl$1@ellebore.saclay.cea.fr

Hello,

After QNX 4.25 C to D upgrade from June 2000 CD, Dev.par now terminates
with
floating point exception at 0005:000007AC

I tried changing BIOS settings without any result, and I see nothing about
in
the documentation. But in patch D release it is said about Dev32.par
changes :
" - Fixed timing loop so that it’s better on newer machines"

sin info says :

CPU: 686/687 Machine: PCI Speed: 2849

The CPU is an Athlon 750 MHz running on a ASUS K7V motherboard.

Is this a known bug ?
Is there any solution ?

Thanks for some help

Arnaud


Arnaud Delmas e-mail: > arnaud.delmas@cea.fr
CEA - CEREM
Centre de Saclay, STA/LMS Bat. 611
F-91191 GIF SUR YVETTE CEDEX, FRANCE
Ph.: +33 1 69 08 48 96 Fax: +33 1 69 08 75 97

I have the same problem.

David Brdicka
dbrdicka@retia.cz


Arnaud Delmas <arnaud.delmas@cea.fr> pí¹e v diskusním
pøíspìvku:8oient$mvl$1@ellebore.saclay.cea.fr

Hello,

After QNX 4.25 C to D upgrade from June 2000 CD, Dev.par now terminates
with
floating point exception at 0005:000007AC

Does Dev.par terminate at startup or when printing? We are running it with
no problems
so far. TIA.

Ivan

Arnaud Delmas <arnaud.delmas@cea.fr> wrote in message
news:8oient$mvl$1@ellebore.saclay.cea.fr

Hello,

After QNX 4.25 C to D upgrade from June 2000 CD, Dev.par now terminates
with
floating point exception at 0005:000007AC

I tried changing BIOS settings without any result, and I see nothing about
in
the documentation. But in patch D release it is said about Dev32.par
changes :
" - Fixed timing loop so that it’s better on newer machines"

sin info says :

CPU: 686/687 Machine: PCI Speed: 2849

The CPU is an Athlon 750 MHz running on a ASUS K7V motherboard.

Is this a known bug ?
Is there any solution ?

Thanks for some help

Arnaud


Arnaud Delmas e-mail: > arnaud.delmas@cea.fr
CEA - CEREM
Centre de Saclay, STA/LMS Bat. 611
F-91191 GIF SUR YVETTE CEDEX, FRANCE
Ph.: +33 1 69 08 48 96 Fax: +33 1 69 08 75 97

Ivan Bannon <ivan.bannon@rjginc.com> wrote:

Does Dev.par terminate at startup or when printing? We are running it with
no problems
so far. TIA.

It will terminate at startup. It does a timing loop to determine how
to essentially poll for printer status in a reasonably friendly way.
On a fast machine, the calculation overflows and later causes a divide
by zero.

The alpha patch referred to earlier in this thread fixes this.

I’ll be darned if I can find the fix. Did it get removed?
If so, is there a workaround?

pete@qnx.com wrote:

Ivan Bannon <> ivan.bannon@rjginc.com> > wrote:
Does Dev.par terminate at startup or when printing? We are running it with
no problems
so far. TIA.

It will terminate at startup. It does a timing loop to determine how
to essentially poll for printer status in a reasonably friendly way.
On a fast machine, the calculation overflows and later causes a divide
by zero.

The alpha patch referred to earlier in this thread fixes this.