PhAB crash, lost work

Has anybody ever experienced a PhAB crash like the following?

Using PhAB, not doing anything particularly unusual (resizing dialog
boxes and widgets), suddenly PhAB disappears. Error is “appbuilder
terminated (SIGSEGV) at 0007:0026C979”. Now every time I try to load my
application in PhAB I get the same error. Unfortunately I was between
backups (oops) and would really like to recover the project rather than
using a backup copy which is pretty old. I talked to a QSSL sales guy
(who else can you get through to nowadays?) who said abapp.dfn was
probably corrupted but he didn’t know what to do about it. I tried
renaming abapp.dfn hoping PhAB would create a new one but then the
application name doesn’t show when opening the application in PhAB.

Anyone have any ideas? Thanks.

I have encountered such a problem but I wasn’t able to find a way to recover
the corrupted abapp.dfn, too. So what I did, everytime I work on PhAB, I
make a copy of the abapp.dfn, naming it abapp.dfn2 or something like that.
When PhAB crashes, I just copy abapp.dfn2 to abapp.dfn. Everytime I build
the application, I also back up the abapp.dfn2. It requires a little effort
but better than losing a lot.


Bruce Davis <bruce.r.davis@boeing.com> wrote in message
news:39BE5146.1024C3E8@boeing.com

Has anybody ever experienced a PhAB crash like the following?

Using PhAB, not doing anything particularly unusual (resizing dialog
boxes and widgets), suddenly PhAB disappears. Error is “appbuilder
terminated (SIGSEGV) at 0007:0026C979”. Now every time I try to load my
application in PhAB I get the same error. Unfortunately I was between
backups (oops) and would really like to recover the project rather than
using a backup copy which is pretty old. I talked to a QSSL sales guy
(who else can you get through to nowadays?) who said abapp.dfn was
probably corrupted but he didn’t know what to do about it. I tried
renaming abapp.dfn hoping PhAB would create a new one but then the
application name doesn’t show when opening the application in PhAB.

Anyone have any ideas? Thanks.

Bruce,
I have had a PhAB termination problem, that I thought was related to
selecting the Resource
Tab while configuring Widgets. Didn’t trap any errors, so I just started
saving work with each step,
assuming the problem was probably my GW2K (233 Pent). Perhaps not 'eh?
Willy

Bruce Davis <bruce.r.davis@boeing.com> wrote in message
news:39BE5146.1024C3E8@boeing.com

Has anybody ever experienced a PhAB crash like the following?

Using PhAB, not doing anything particularly unusual (resizing dialog
boxes and widgets), suddenly PhAB disappears. Error is “appbuilder
terminated (SIGSEGV) at 0007:0026C979”. Now every time I try to load my
application in PhAB I get the same error. Unfortunately I was between
backups (oops) and would really like to recover the project rather than
using a backup copy which is pretty old. I talked to a QSSL sales guy
(who else can you get through to nowadays?) who said abapp.dfn was
probably corrupted but he didn’t know what to do about it. I tried
renaming abapp.dfn hoping PhAB would create a new one but then the
application name doesn’t show when opening the application in PhAB.

Anyone have any ideas? Thanks.

Not sure exactly how my problem started. I had to work from my last backup.
I was able to import some of the modified widgets without any problems
though.

Willy wrote in message …

Bruce,
I have had a PhAB termination problem, that I thought was related to
selecting the Resource
Tab while configuring Widgets. Didn’t trap any errors, so I just started
saving work with each step,
assuming the problem was probably my GW2K (233 Pent). Perhaps not 'eh?
Willy