NFSD Nested Folders


QNX (6.1) NFSD runs ready when a create dir attempt is made in a folder that is nested 16 directories deep. I tried QNX 6.2 and 6.3 and it still hasnt been fixed. (Doesnt run ready, but still fails)

Is this a known problem? Does anyone have a fix or an other NFSD I can use?


A couple thoughts about this.

Do you get any errors in either syslog or sloginfo? They may tell you what is wrong.

It is also possible you are hitting some limit. Look at the usage of nfsd and try overriding some of the cache sizes with bigger numbers.


Hello Rick,

Thanks for your quick responce. I tried your suggestion by doubleing all the cache sizes from the defaults. Same problem. No messages in syslog :frowning:
Seems like sometimes it just dies and sometimes it run’s ready.

Thanks! Brendan

Interesting… I wonder if are hitting a stack overflow? Before you make it crash, ‘pidin -P nfsd mem’ will show the stack usages (last column). Other than that, try approaching QSS with a bug report - especially if you cause it to crash and have a core or something - preferably from 6.3 since that is the current version.


Hi. On QNX6.3 it dosnt crash. I just get the below message from the client.
mkdir -p 1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17/18
mkdir: cannot chdir to directory `1/2/3/4/5/6/7/8/9/10/11/12/13/14/15/16/17’: Stale NFS file handle

Do you know of any other NFSD that runs on QNX? I have a feeling it will take QNX a while to fix this. (I called them and they did not know of the problem; but since I dont have a contract with them Im not sure if I will get a fix…)

Nope - on the other hand, if it is as simple to reproduce as you demonstrated, they will probably fix it - of course the fix may be a little while in appearing, but it should appear eventually.

The server in your case is obviously QNX, but what is the client running? Have you tried it from a different client (os)? I suppose it could be possible the client is the problem - not that it will necessarily help. Also do you know if the client is talking nfs2 or nfs3? And what happens (if anything) if you change to the other?



I have tried it with a number of different clients (Windows Unix Services, Linux 2.4, etc…) and the same problme happends in all. I just ported over the linux unfs3-0.9.10 project to QNX with the help of another guy. (Not much work). This one doesnt suffer from the same problem, although there might be other quarks with it.

Do you think that someone else might be interested in this port?

Thanks Very much for all your help today!


Great… glad you got a solution.