Can't get rsh to run, always get rpcPpermission Denied

How do you get rsh to work on a QNX system?
I have tried all I can think of.
Here’s the problem.
We have a couple a QNX systems and a Solaris system. I am trying to be
able to run a make on the QNX system remotely from the Solaris system…
Ok, in my user account, same username on both systems, I put the Solaris
system name, as in the qnx /etc/hosts file, in my .rhosts.
On the solaris system I run the infamous
rsh cat >>
I get an rpc: Permission denied error.
I try putting the actual IP of the solaris system in the .rhosts, no
good, same thing. I put It in the qnx /etc/hosts.equiv file both ways,
still get same error.
I can get this command to remotly execute on a Linux system and from
Linux to solaris after setting up the .rhosts file just like advertised.
I even tried qnx from qnx , get same error.
Any ideas on what I am missing???
I know this has worked in the past as it was used by previous employees.
The only thing is we moved and changed providers which changed our IP
domain addresses. Which were changed in the system’s /etc/hosts files.

Jeff Pierce

In article <>,
Jeff Pierce <> wrote:

How do you get rsh to work on a QNX system?
I have tried all I can think of.

yep I know the story, its a bit hit and miss, but you can do it. make sure
your /home/$USER/.rhosts file is -rw-------- and make sure that you order
your /etc/hosts with the first name being the one you used in .rhosts, also
make sure the user ID’s on both systems are the same number (not sure if
thats important or not)

so with a user e.g. jeff and a .rhosts (e.g. /home/jeff/.rhosts) like:

sun.mydomain.blah.blah jeff

make sure you have an /etc/hosts like:- sun.mydomain.blah.blah mysun

and you should be fine.


Lance Roberts

Sent via
Before you buy.