problems with realtek-ethernet card


does anybody know something about problems running ethernet cards with realtek chip under qnx? qnx doesn’t find my ethernet card…or how can I manually install this card?


The QNX 6.2.1NC beta has somehow gone screwy on detecting the rtl-8139 ethernet cards, some devices auto-detect no problem while others just should.

The network will work fine if you slay io-net and manually start it again with the rtl driver, and no I don’t know how to do this.

I submitted a bug report on this a couple of weeks back.

thanks - that’s what I presumed
now I tried to start network manually by:

“io-net -d rtl -p tcpip”

but there’s an error like: “no such device”
although I have seen my device by typing “pci”

should I create the device entry in /dev - directory before or what?


You can try with ne2000 driver.
that is
“io-net -dne2000 -ptcpip”

mirtch - are you using 6.2.1? Have you installed the Momentics packaged? It is important since the rtl driver won’t work until you finish the install.

I just solved the problem: after I changed the card’s pci-slot on my board it worked…

thanks anyway!