telnet & ftp: long connect times


I have a QNX 6.2.1 machine which is connected to a switch. The switch and other PC’s are connected to an ADSL router.

On the QNX machine I put the router as gateway and DNS server.
I tried to connect to the internet via from the QNX machine: succesfully.

When I try to connect me via telnet or ftp from a windows machine to the QNX machine, I have very long connect times. (The ftp client cancels the connection).

In the file “/etc/hosts” I don’t added the windows machines, because I want to use plain IP addresses.

When I connect me locally on the QNX machine via telnet using his IP I have the same long connect times. If I use “localhost” I get a fast login.

The command “netstat -a” also stays for long times. If I use “netstat -an” it works fast.

In the following thread I read that is a DNS/lookup problem: … et+connect
As a solution they write about completely turn off DNS.

But I want to use DNS for the internet.

Why makes the telnet/ftp server a name lookup while connecting ?

What is te right way to resolve this problem?

When a PC from the internet trys to connect to the QNX PC, would the connect time also so long ?

Thank you very much for your help !

Best regards


You can still add the windows box in your QNX’s /etc/hosts even though you are using plain IP addresses. Just put a fake name in there.

that’s because “localhost” is already in the /etc/hosts file.

well, then you need to either fix your DNS to cover the subnet that your Windows box is on.

I don’t think there is a way to tell telnetd/ftpd NOT to use DNS without turning off DNS for the whole system.

Not if the IP for that PC is properly in DNS.

Hello noc,

thanks for the info.

I have to try it from the internet…