Problems with touch screen...

I am having trouble getting a Dynapro SC3 touch controller working with
QRTP. I am using a 6.4 inch screen at 640x480.

I run the following (I am hooked up to COM1):

devc-ser8250 -b 2400 &
devi-dyna dyna -b 2400 fd -d/dev/ser1

I get a cursor, but it doesn’t follow where I press on the touchscreen.
Occasionally QRTP will start an application or something as I randomly
press around on the screen. So I run calib and it shows me the target.
When I try to press on the target, nothing happens. So I press
elsewhere, if I tap randomly around it will eventually move the target,
but the finger presses never match the target. And the mouse cursor is
sometimes on the screen, sometimes off the screen depending on where I
press. I put it on a serial port monitor, looks like the SC3 is sending
6 bytes when I touch the screen, don’t know what they mean. But the
serial port settings seem to be correct. Any clue what is wrong? I
suspect something may be wrong with calib. BTW, I had this working
before under QNX4 and Photon 1.14. Thanks.