Compact Flash Boot Problems


Has anyone been able to boot QNX 4.25 from a Compact Flash card on an EIDE
interface? If so could you describe your procedure?

I have a single board computer (Teknor MXS64) with an onboard Compact Flash
plugged into the Primary EIDE Channel (as master). I start out wiping every
track clean with a utility supplied by Teknor and Install using the QNX
install boot disk and CD-ROM. It seems to install fine, but when it
reboots it hangs either at the “Press ESC for alternate OS” message or when
it tries to mount the Compact Flash volume. QNX states that it’s OS just
thinks it’s a standard EIDE device and that it should be no problem.

I’ve tried using the Fsys.ata drive suggest for 4.24 installation and I get
continous crash/reboot sequence. I’ve also tried explicitly stating the CHS
in the Fsys.eide drive… all to no avail. Just another note, the volume
seems fine because I am able to mount it as a slave on a another system
(that boots from a std. hard drive).

Does anyone have any ideas?

David Scarlett