Samba & Windows 'Network Busy'

Hi,

I am currently running Samba 2.0.7 on QNX 4.25 and running into an access
problem
for my Samba shares. I have several different winX machines trying to
access
my QNX box and Samba is setup to share the users folder. I have been able
to get
access to the share from network neighborhood and even map a local drive
letter
to the share. But, most of the time when I initially try to access the
share (after
rebooting WinX) I get a ‘Network Busy’ error dialog from windows and the
following
in my log.smb file:

[2001/01/30 10:42:55, 0] lib/util_sock.c:(540)
write_socket_data: write failure. Error = Broken pipe
[2001/01/30 10:42:55, 0] lib/util_sock.c:(566)
write_socket: Error writing 4 bytes to socket 6: ERRNO = Broken pipe
[2001/01/30 10:42:55, 0] lib/util_sock.c:(754)
Error writing 4 bytes to client. -1. Exiting

This keeps repeating until it eventually works. Sometimes it works after a
few minutes
and sometimes it takes a few hours. It is a rather annoying intermittant
problem.

I have run thru the diagnosis.txt and the other docs in the Samba folder but
no luck
with this problem.

Here is my smb.conf:

[global]
workgroup = MIL-DOMAIN1
server string = IP # 006 : QNX Server #1
security = user
encrypt passwords = yes
guest account = guest
wins server = 192.168.0.1
local master = no
os level = 1
domain master = no
preferred master = no
hosts allow = 192.168.0. 127.
interfaces = en1

[homes]
comment = Home Directories
browseable = no
writable = yes

[Network In]
path = /NetworkIn
comment = Shared Input Folder
writeable = yes

[Network Out]
path = /NetworkOut
comment = Shared Output Folder
writeable = no

I have also run into delays waiting for ftp to open sessions but after
logging in it will ls and browse fine but when transfering (i.e. opening
a new thread and connection) it takes several seconds to start. Ping
and telenet work fine along with phindows.

Thanks…

~ Lee R. Copp
~ Project Engineer (EE/ME)
~ Michigan Scientific Corp.
~ 321 East Huron St.
~ Milford, MI 48381
~ 248-685-3939 x109 (V), 248-684-5406 (Fx)
~ http://www.michiganscientific.com
~ mailto:<Lee.R.Copp@MichiganScientific.com>

hmmm… I just followed up in qdn.public.qnx4. check it out…

rick

btw: I thought cross-posting was disabled by now…

“Lee R. Copp” wrote:

Hi,

I am currently running Samba 2.0.7 on QNX 4.25 and running into an access
problem
for my Samba shares. I have several different winX machines trying to
access
my QNX box and Samba is setup to share the users folder. I have been able
to get
access to the share from network neighborhood and even map a local drive
letter
to the share. But, most of the time when I initially try to access the
share (after
rebooting WinX) I get a ‘Network Busy’ error dialog from windows and the
following
in my log.smb file:

[2001/01/30 10:42:55, 0] lib/util_sock.c:(540)
write_socket_data: write failure. Error = Broken pipe
[2001/01/30 10:42:55, 0] lib/util_sock.c:(566)
write_socket: Error writing 4 bytes to socket 6: ERRNO = Broken pipe
[2001/01/30 10:42:55, 0] lib/util_sock.c:(754)
Error writing 4 bytes to client. -1. Exiting

This keeps repeating until it eventually works. Sometimes it works after a
few minutes
and sometimes it takes a few hours. It is a rather annoying intermittant
problem.

I have run thru the diagnosis.txt and the other docs in the Samba folder but
no luck
with this problem.

Here is my smb.conf:

[global]
workgroup = MIL-DOMAIN1
server string = IP # 006 : QNX Server #1
security = user
encrypt passwords = yes
guest account = guest
wins server = 192.168.0.1
local master = no
os level = 1
domain master = no
preferred master = no
hosts allow = 192.168.0. 127.
interfaces = en1

[homes]
comment = Home Directories
browseable = no
writable = yes

[Network In]
path = /NetworkIn
comment = Shared Input Folder
writeable = yes

[Network Out]
path = /NetworkOut
comment = Shared Output Folder
writeable = no

I have also run into delays waiting for ftp to open sessions but after
logging in it will ls and browse fine but when transfering (i.e. opening
a new thread and connection) it takes several seconds to start. Ping
and telenet work fine along with phindows.

Thanks…

~ Lee R. Copp
~ Project Engineer (EE/ME)
~ Michigan Scientific Corp.
~ 321 East Huron St.
~ Milford, MI 48381
~ 248-685-3939 x109 (V), 248-684-5406 (Fx)
~ > http://www.michiganscientific.com
~ mailto:> <Lee.R.Copp@MichiganScientific.com>

btw: I thought cross-posting was disabled by now…

I didn’t cross post…I posted twice…I figured post into
the ‘masses’ of comp.os.qnx and get the shotgun effect
and post into the ‘localized’ of the new qdn.* and get
the sniper effect…:slight_smile:

I know QSSL frowns on cross-posting inside the qdn
domain but who runs this newsgroup??

~ Lee R. Copp
~ Project Engineer (EE/ME)
~ Michigan Scientific Corp.
~ 321 East Huron St.
~ Milford, MI 48381
~ 248-685-3939 x109 (V), 248-684-5406 (Fx)
~ http://www.michiganscientific.com
~ mailto:<Lee.R.Copp@MichiganScientific.com>