Multi display on QNX 6.3 evaluation

I have two video cards

  1. RADEON series 9200 bus AGP
  2. S3 Trio 32 / 64 bus PCI

I would like to manage two displays with different images on each display.
How can I do this ? I try with the io-graphics command but the result is not
OK.

jbb

If you search “multiple display” in the io-graphics document for QNX 6.3, you will see only radeon and matrox are supported. I guess your S3 is out of luck.

BTW, here is the step by step document on setting up multiple displays.

Can I do this using Photon 1.12 (QNX 4.25)?
Thanks

Paulista

For QNX 4, follow this document:

qnx.com/developers/qnx4/qnx4 … ?code=9490

The first statement is:

“To use multiple monitors under Photon, you must be running at least version 1.13 of Photon which includes the Hydra.ms trapper/mode switcher.”

Do you know if it is possible using Photon version 1.12??

Thanks again

Hi!
Please tell me the way to package an Application with QNX ?
Or
Is there any Tool run in QNX OS that can Package an Application (similar to the InstallShield Tool belong to Visual Studio 6.0)?

Thanhks in advance!

Never tried myself, so I don’t know.
But you could either try it with your v1.12 or just upgrade to 1.13. Last I remember, this upgrade is easy, painless and free.

You should post your question with a new topic rather than hijacking this one.

To answer your questions quickly, please refer to the following two articles:
qnx.com/developers/articles/ … 883_1.html
qnx.com/developers/articles/ … 877_1.html

I had tried upgrade to 1.14 and, I don´t know why, unfortunatly it was not work, I can compile my application but it is impossible to run.
Do you know any problem that can do it?
Now I´ll try upgrade to 1.13.
Thanks

Does anyone know where I can download version 1.13?

I can see both 1.13 and 1.14 on quics. If you don’t have access, you will need to contact your QNX sales rep.

BTW, what’s the problem you had when you upgraded to Photon 1.14 runtime?

Actually the matter was not about Photon Runtime 1.14, it working fine.
The problem is happening when I try to run an application that I´ve just compiled using Photon Toolkit 1.14 (PhAB) under Photon Runtime 1.14. (???)
This application was wrote, originally, under AppBuilder 1.12 and it works very well in Photon Runtime 1.12. Now I want to upgrade that to be able to run in Photon Runtime 1.14, I can compile it but I can´t to do it runs.
When I try to run this application in Photon Runtime 1.14 the system goes out, when I try to run it in Photon Runtime 1.12 it works fine (the same executable made using Photon Toolkit 1.14. yes, it´s working under 1.12 but not under 1.14).

I hope you understand my explanation, I know it´s a little confuse.

Is there anything that I have to do??

Thanks a lot

When my application goes away the next information has been shown:

//2/home/coe5/MYAPLLICATION terminated (SIGSEGV) at 0007:00072F70

I´ve tryed to use wc to find a error, and it´s happening when program try to display main windown calling:
ApLinkWindow(NULL, &appl_links[0], NULL);

I did not understand because this code is generated for PhAB by itself.

Any idea?

Could be the photon shared libs are incompatible between 1.12 and 1.14.
Make sure your system has phrt and phtk version match. Check out the /usr, /qnx4 to make sure you don’t have other older versions lying around on the system.