Bittorrent and QNX

Hi all!

All is working well at the moment on my QNX 6.2.1.

Now i want to to use a Bittorrent-Client.

There are 3 possible Clients: Azureus (Java), ABC and BitTorrent (bothein python).

First I tried Azureus, but i didn’t get it to work. This could be , because the Java-Platdorm in QNX doesn’t support graphical components.

The other both Clients need phyton to run. So I installed it. But both needs also pkg-config and wxPython. So i tried to install pkg-config In ./configure there was no error, but if I make “make” he stops with an error:

gcc -DHAVE_CONFIG_H -I. -I. -I. -DG_LOG_DOMAIN=g_log_domain_glib -g -O2 -Wall -D
_REENTRANT -c gerror.c -o gerror.o
gerror.c: In function `stack_trace':
gerror.c:233: request for member `fds_bits' in something not a structure or unio
gerror.c:248: warning: passing arg 2 of `select' from incompatible pointer type
gerror.c:252: request for member `fds_bits' in something not a structure or unio
make[4]: *** [gerror.lo] Error 1
make[4]: Leaving directory `/root/pkgconfig-0.15.0/glib-1.2.8'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/root/pkgconfig-0.15.0/glib-1.2.8'
make[2]: *** [all-recursive-am] Error 2
make[2]: Leaving directory `/root/pkgconfig-0.15.0/glib-1.2.8'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/root/pkgconfig-0.15.0'
make: *** [all-recursive-am] Error 2

wxPython makes trouble in configure:

checking build system type... i386-pc-nto-qnx6.2.1
checking host system type... i386-pc-nto-qnx6.2.1
checking target system type... i386-pc-nto-qnx6.2.1
configure: error: unknown system type i386-pc-nto-qnx6.2.1.

Do someone have experiance with Bittorrent and QNX? It is equal which client i can use, but i need one :slight_smile:

Thanks so far…

pkg-config can be found on the 3rd party CD or online repository.

not sure about wxPython, but you could check the qnx python project at

The make error about fd_set is simply that you need to #include <sys/select.h>

Where i must put this - #include <sys/select.h> to make it work? Thanks

Probably at the top of gerror.c


I just wanted to ask if you´ve managed to install azureus or another bt client?

Perhaps it´s possible to start Azureus with Web Sphere.

Best Regards