Some problem in GCC on QNX 6.3

I installed QNX 6.3
But gcc did not work.

first, shell could not fild gcc. so I find gcc and set PATH.
( export PATH=$PATH:/usr/qnx630/host/qnx6/x86/usr/bin )
after did like that, i tried to gcc. but still doesn’t work.
message is
gcc: environment variable QNX_HOST not defined

and then I did like this.
export QNX_HOST=“x86”

I tried to compile my program. but didn’t work again
gcc: installation problem, cannot exec ‘cpp0’: No such file or directory

so I find cpp0 and do this.
export PATH=$PATH:/usr/qnx640/host/qnx6/x86/usr/lib/gcc-lib/ntox86/2.95.3

finally, I doing compile my source… error… :imp:
No include path in which to find stdio.h
No include path in which to find stdlib.h
No include path in which to find Pt.h

Please help me :’(

I solved this problem myself.
Cause was BASH.
I hate ksh. So I changed my shell to bash.
Result of this, /etc/profile did not excute and then /etc/profile.d/*.sh did not excute either.

There are some kind of solution, so I don’t mention it.

If you copy/symlink /etc/profile.d/.sh to /etc/profile.d/.bash, you should be good to go using bash as the login shell.