QNET on only 1 of multiple NIC's


I was wanting to start QNET on only 1 of multiple NIC’s on my 6.3 machine. I figure the best way is to run multiple copies of io-net and have each one customized.

I was trying to figure out how to do this during startup. How would I create an enum override file that used the -i option of io-net and mounted npm-qnet.so to select ones??


OK, I’ve figured out half of this problem, here’s the next question(s):

  1. How do you get two ethernet devices to work simultaneously? I have en0 and en1 running. In phlip I have both configured with the exact same IP and netmask and both clicked as enabled, and neither NIC will work - I have to disable. However netstat -rn lists the gateway as only through the one NIC - how do I change this to the other?? How do I enable both NIC’s?

  2. The other problem I have is that I have one NIC (network chip) on the motherboard (devn-via-rhine) and another 2 in PCI slots (devn-el900). Yet I only get 2 ethernet devices in /dev/io-net, one is en0 (the lower of the two PCI slot cards) and the other is en1 (the via chip), where is the other PCI slot card and how do I get a hold of it.

Anyways, I hope those questions make sense - I’m not a networking expert just yet…

OK…I’ve been able to get 2 NIC’s up and running and I can get QNET to work over both.

My latest problem is that I am using the following command in /etc/system/sysinit:

mount -Tio-net npm-qnet.so -o bind=/dev/io-net/en1

however, I can still access this machine via QNET over en0 which seems very odd to me. I want to run QNET on en1 but not on en0. Any thoughts - thanks.

All the “mount” options have to go BEFORE the .so file:
mount npm-qnet.so

So, in your case, try

mount -Tio-net -o bind=/dev/io-net/en1  npm-qnet.so 

I talked to cdm earlier today and that worked except that I also changed /dev/io-net/en1 to just en1 so:

mount -Tio-net -o bind=en1 npm-qnet.so