cron: skipping crontab without user: root

I’m trying to get cron running on my Audrey (QNX 6). I copied cron
and crontab over to it, as well as creating
/usr/spool/cron/crontabs/root and /var → usr

But when I run cron -v &, I get the following message:

cron -v &

[1] 2396203

cron: ** started Dec 02 04:14:06

cron: skipping crontab without user: root


Is there a library I’m missing? What would normally cause this error?
None of the tasks listed in /usr/spool/cron/crontabs/root are running
so I don’t think cron is working right…

John Hamm <john@snapjax.com> wrote:

Hm… could it be an /etc/passwd file problem? cron may be looking
for root in the password file, and I don’t know if you have one installed/
setup.

-David

I’m trying to get cron running on my Audrey (QNX 6). I copied cron
and crontab over to it, as well as creating
/usr/spool/cron/crontabs/root and /var → usr

But when I run cron -v &, I get the following message:

cron -v &

[1] 2396203

cron: ** started Dec 02 04:14:06

cron: skipping crontab without user: root



Is there a library I’m missing? What would normally cause this error?
None of the tasks listed in /usr/spool/cron/crontabs/root are running
so I don’t think cron is working right…


QNX Training Services
I do not answer technical questions by email.

Hm… could it be an /etc/passwd file problem? cron may be looking
for root in the password file, and I don’t know if you have one installed/
setup.

-David

David, that was it exactly! It is running now. I am getting strange
behavior from cron though. It seems that I must use “00” instead of
“0” when specifying the minute parameter in a crontab entry. If I
don’t it doesn’t run…

Is this expected? Are there any more padded zeros that need to be
entered? I didn’t notice this in the man… thanks for all your help!

John Hamm <john@snapjax.com> wrote:

Hm… could it be an /etc/passwd file problem? cron may be looking
for root in the password file, and I don’t know if you have one installed/
setup.

-David

David, that was it exactly! It is running now. I am getting strange
behavior from cron though. It seems that I must use “00” instead of
“0” when specifying the minute parameter in a crontab entry. If I
don’t it doesn’t run…

Is this expected? Are there any more padded zeros that need to be
entered? I didn’t notice this in the man… thanks for all your help!

This is not expected to me. I don’t have any suggestions as to
why it might want that or what is going for that.

-David

QNX Training Services
I do not answer technical questions by email.