python 2.2.2 on QNX 6.2.1

Hi, I am new in this group.
I recently installed python 2.2.2 (from 3rd party CD)
on my QNX 6.2.1 box (dual PIII 1GHz CPUs with 1GB memory).
I tried to run python there, but the startup time takes about 10 seconds
(from typing “python” on the shell till python prompt showup).
Is this normal? Why does it take so long? Or do I miss something?

Have you tried the python build for qnx6 from ?

I just tried building the python 2.2.1 for QNX6 from SourceForge.
It looks much normal now. But I can only build the core,
not those extension modules. Anyway to fixthis?
BTW, I also tried the python 2.2.1 from the older version
3rd party CD. It’s also very slow to startup.

It has to do with fs-pkg. If you run a “hog -n -%1” while you start python you will see that fs-pkg is consuming an insane amount of CPU time while python starts. This will hopefully be fixed in a future release. You can either get the 2.2.1 from openqnx or the 2.2.2 sources from the 3rd Party CD and rebuild and install without a package. The openqnx version doesn’t include the shared however.

Thanks for the reply.
I couldn’t find python 2.2.2 source from the 3rd party CD.
Is that installed under /pkgs/repository?
Also I have problem building extension modules in the 2.2.1
from openqnx. Is that becuase is not included?


if I run python with “-S”, the startup time is only about
one-third or half of with “-S”. So I guess the long delay
has something to do with importing those default modules.

Earlier when I ran the 2.2.1 python core that I built locally,
it was very quick. I guess part of the reason is I failed to
build those extension modules at that time. So it doesn’t
spend time loading them when startup.