SanDisk usb CF card reader installation problem under QNX6.3

Hi, all
I tried to install a CF card reader as follows,

#io-usb -d uhci
#devb-umass cam pnp

with the following output:
#Path=0 - QNX USB storage

and there is no new hd[X] under /dev

what’s is wrong?

#usb -vvv

Device Address : 1
Upstream Host Controller : 0
Upstream Device Address : 0
Upstream Port : 0
Upstream Port Speed : Full
Vendor : 0x0781 (SanDisk )
Product : 0x9191 (ImageMate CF)
Device Release : r0.32
USB Spec Release : v2.00
Serial Number : 0100632811
Class : 0x00 (Independant per interface)
Max PacketSize0 : 64
Languages : 0x0409 (English)
Current Frame : 551 (1024 bytes)
Configurations : 1
Configuration : 1
Attributes : 0x80 (Bus-powered)
Max Power : 500 mA
Interfaces : 1
Interface : 0 / 0 (CF)
Class : 0x08 (Mass Storage)
Subclass : 0x06 (SCSI)
Protocol : 0x50
Endpoints : Control + 2
Endpoint : 0
Attributes : Control
Max Packet Size: 64
Endpoint : 1
Attributes : Bulk/IN
Max Packet Size: 64
Endpoint : 2
Attributes : Bulk/OUT

I have a SanDisk ImageMate CF (SDDR-91) and this is in the /etc/rc.d/rc.local file:

io-usb -dehci -dohci -duhci
waitfor /dev/io-usb/io-usb
devb-umass cam pnp

My guess is this card falls under one of the other protocals.

Hi, betweddl,
Mine is SanDisk ImageMate CF (SDDR-91-A15), I bought this card reader this morning following some previuos post,
but unfortunately, it looks like this does’t work well for me, I probably need to try other brand.

thanks for your reply.

Try using Brent’s example. I think you’ll find it works.

The only reason for it to fail is an IRQ sharing problem which can als be rectified by moving cards around in the PCI slots.

Brent and Evanh,
Bought a PCI usb card, still not working though, even the system response is the same,
but an 128M usb flashdrive is working fine.
I guess my luck on this reader is over.
any suggestions?
Do you guys have some other successful examples?
thanks

Try another CF card. In the end most of my problems were solved by using an old CF card that came with a friend’s digital camera.

four CF cards have been tried, no luck.
SimpleTech 128Mb, Apacer 128Mb, Canon 16Mb, Viking 128Mb.
Any other successful stories for PC?
will try a MAC.
The problem is that I don’t get it why they fail to provide adequate support for such a widely used piece of hardware?
But I do believe there shoud be no technical difficulties in doing so.
Are they trying to lead us in a direction that we need to buy QNX or QNX favorite hardwares in order to use their software?
I love the flexibility and stability in QNX, but I am kind of frustrated by this situation.
Wish all my concerns are proved to be wrong.

Remove any USB devices like mouse and keyboard. If such devices were attached then you prolly have some oddball emulation operating that will interfere and will also need to be disabled in the BIOS.

After a clean boot, “io-usb -dehci -dohci -duhci”
Are you getting a “/dev/io-usb/io-usb” entry?

Brent and evanh,
Solution found by using a differrent card reader,
if you guys are interested the reader information,
post your email address here.
BTW, there is no usb device except the CF crad reader on this PC.
Thanks

I’m using a SanDisk ImageMate CF Model #: SDDR-91 with no problems…that surprises me. Please send over the info for my future reference,

Thanks - betweddl@warg.uwaterloo.ca

Faulty reader maybe.

evanh,
The SanDisk reader works fine in Windows and Linux,
and there is a “/dev/iso-usb/iso-usb” entry in QNX.
anyway, the porblem has been solved, I can move on to some fun stuff.
thanks

I am having a similar problem. I have tried two different card readers. Please email me the manufacturer/model number of the card reader that worked for you.

j_melchiorre@yahoo.com.

Thanks.