devb-eide and HPT374 based RAID Controller

How do I get devb-eide to recognise my HD ?

I have a High Point 1640 SATA RAID Controller, its main chip is the HPT374 which is supported by QNX (there web site), pci gives me this info:

vid=0x1103, did=8, pci index=0, bus=0, ioports=0x9000,0x9400,0x9800,0x9C00,0xA000, irq=10

and

vid=0x1103, did=8, pci index=1, bus=0, ioports=0xA400,0xA800,0xAC00,0xB000,0xB400, irq=10

I have tried, detecting it with vid,did but nothing is found

devb-eide eide vid=0x1103,did=0x0008,pci=0,cntl=0

If I use IO addresses I can get each of the following lines to detect a single HD connected to the controller.

devb-eide eide ioport=0x9000,irq=10
devb-eide eide ioport=0xA400,irq=10

I have tried ā€œioport=0x9000:0x9800ā€ but nothing new.

I have 4 working drives connected to this controller, configured as a RAID 5 array, I expected the controller to show me 1 drive of 480Gb in size, instead I can only find two of my four 160 Gb drives.

Ok, what am I doing wrong ?