Installing a lean QNX 6.3


installing QNX 6.3 takes about 160 MB. Because i have to put it on a 128 MB CF-Card i don’t want to delete various / most programs i don’t need. What is the smartest way for doing this?
Or is it possible after booting the installation iso not to install the hole content?

Thank you,

sure, try this post:

you can skip step 5 mentioned there.

Thank you for the hint.
It worked fine still I reboot my system.

This produces the message “Missing operating system”.
I tried “fdisk /dev/hd0 loader”
and “dinit -b /dev/hd0t79”

What can I do to boot successfully?

I’ve see lots of people having issues booting CF card …
Read those old postings and see if you can find a solution.

or, you can try using grub/loadifs booting solution as discussed in


the solution was to enable LBA adressing in Bios!
I don’t understand this, because before i had to CHS to “see” the newly created partition and now I have to reactivate LBA to boot successfully…Ah, what the heck, now it does!

Thank you very much!

i’ll come back to an offer you originally made to “peat” :

  • come back if you stuck anywhere -

PC with formerly 3 partitions WIN98, qnx4.25, qnx 6.2.1, not any problem since months
reinstalled (updated) qnx4.25
right after that can’t boot into qnx6.2.1 any more

i wiped the boot record with DOS’s fdisk /mbr

i can make a 79type partition under qnx4.25
i can make a 79type partition under qnx6.2.1 from cd, or qnx6.2.1 creates it during the install procedure

i can dinit the 79type partition from qnx4.25, i can mount it, i can copy to it, e.g. qnxbasedma.ifs, to start a boot with a couple of dots after a shutdown

i cannot dinit the 79type partition, and it is not within /fs when starting qnx6.2.1 from the cd. the fully bootable and working 77type partition does not show up either, only cd0. of course i cannot boot into qnx6.2.1, but for a couple of dots

the funny thing is, everything worked perfectly well before, so i believe it cannot be the master/slave thing. as i hold an up-to-date backup of all my files, the problem is not serious, but i am not yet prepared to buy a new harddisk. i am ready to even hack into the boot sector of the hd, if only someone could point me to a good article about this issue.

thanks HELGE

seems like something is mixed up here. i thought i made the above post under viewtopic 12720, and no, it is afternoon here in Germany and no, i haven’t had usual glass of wine yet.

You must be drinking :slight_smile: I tried and it says there is no viewtopic 12720.

Guess you may be referring to this post of mine which is for QNX 6.3 and QNX 6.21 is totally different.

when you go to this link :

in the last post there is an ‘above post’ link to 12720, which again in it’s very last post has an ‘above post’ link to itself.

never mind - now i think viewtopic 3212 is the very right place for my question. maybe i am not drinking, but sitting in front of a foreign WINDOWS machine (mind my QNX machine is not in working condition), whose internet explorer drives me insane with all those windows popping up - never happened in QNX.

thanks for the quick answer. in case you got nothing more important to do, i could give you a phonecall right now, if you have any ideas about my problem.

regards HELGE

Well, that whole thread is about QNX 6.3 and I don’t see you have it on your problem machine.

The dinit in QNX 4 and 6 are NOT compatible as far as the boot sector goes. That’s why you see all the dots booting up the t79 that was dinit’ed from QNX 4.

After you boot up the QNX 6.21 CD, do you see any partitions in /dev ? what does “fdisk /dev/hd0 show” say?

no, I don’t see any partitions in dev (neither DOS (11) nor QNX (77 and 79))
fdisk show says :

  1. FAT32 11 0(start cyl) 728(end cyl) 11717234(blocks) 5721(size) MB
    and reasonable entries for QNX and QNZ

Haven’t used QNX 6.2 for a while. Below are from memory:

Run “ls /dev” and you should see /dev/hd0, and possibly all partitions (/dev/hd0txx). If you don’t see those partitions, try “mount -e /dev/hd0” and look “ls /dev” again.

Now, hopefully you can “see” /dev/hd0t79 and can format it “dinit -hNR /dev/hd0t79”. You can then mount this new partition and copy the /boot directory from the CD, as well as the boot file.
mount /dev/hd0t79 /newmnt
cp -pr /fs/cd0/boot /newmnt/boot
cp /fs/cd0/boot/fs/qnxbasedma.ifs /newmnt/.boot
cp /fs/cd0/boot/fs/qnxbase.ifs /newmnt/.altboot

boot the new partition and finish up the installation.

Thanks, noc, but I think I shall give up here and kick the drive into the bin.
That is exactly the problem : I have been able to create, delete, shrink etc. any kind of partition on the very drive under DOS and QNX4 and QNX6.x for months now, with re-installing or updating all three OSes for various times.
I have tried all the mount options under 6.2 and 6.3, no way to see any partition from these OSes. Remember QNX6.x is able to create a partition with fdisk, but is not able to see or dinit it. I have to read some more books.
Regards HELGE