lpr/lpd is modifying raw data on its way to the printer

I am using a specialized printer (Star Micronics TSP800) connected to the
parallel port on QNX 4.25c, and remote printing from linux. I want to spool
a raw file with no filters or changes of any kind whether to the control
codes or the raster images. I can do this successfully with both local and
remote printing with linux, but there are problems with both local and
remote spooling when the printer is connected to the QNX box. When I put
the printer into hexadecimal dump mode I confirm that what the printer
receives is significantly modified from what has been spooled, with large
portions removed.

I am calling lpr with the “-l” parameter, and the printcap has no input or
output filter specified, and suppresses form feeds and headers. What is
changing the data being sent to the printer? Is there some default filter
to be suppressed?

If
stty < /dev/par
show opost set, turn it off (stty -opost < /dev/par).

Richard

“Eugene J Pascal, CD.” wrote:

I am using a specialized printer (Star Micronics TSP800) connected to the
parallel port on QNX 4.25c, and remote printing from linux. I want to spool
a raw file with no filters or changes of any kind whether to the control
codes or the raster images. I can do this successfully with both local and
remote printing with linux, but there are problems with both local and
remote spooling when the printer is connected to the QNX box. When I put
the printer into hexadecimal dump mode I confirm that what the printer
receives is significantly modified from what has been spooled, with large
portions removed.

I am calling lpr with the “-l” parameter, and the printcap has no input or
output filter specified, and suppresses form feeds and headers. What is
changing the data being sent to the printer? Is there some default filter
to be suppressed?