problems installing bash in 6.1

Hi,

I’m trying to install the gnu bash in the 6.1 ver and it pops up the following message: “Missing license file for package GNU Bash (bash-2.04-bld2-gnu)”

I have a qnx license, but i have only a paper, no file.

What should i do?

You trying to install it from my site? Install the 6.1 package.

http://staff.qnx.com/~cdm/repository.new/

chris


Benzy Gabay <bgabay@everbee.com> wrote:

Hi,

I’m trying to install the gnu bash in the 6.1 ver and it pops up the following m
essage: “Missing license file for package GNU Bash (bash-2.04-bld2-gnu)”

I have a qnx license, but i have only a paper, no file.

What should i do?

cdm@qnx.com > “The faster I go, the behinder I get.”

Chris McKillop – Lewis Carroll –
Software Engineer, QSSL
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

Well I was trying at first to install the file from your site, but now after
installing the 6.1 release I see that I have the same problem with the 6.1
installation cd repository.

now what?

Benzy Gabay
R&D
Everbee Wireless
mailto:bgabay@everbee.com
tel. +972-9-956-0135
fax. +972-9-955-9654

“Chris McKillop” <cdm@qnx.com> wrote in message
news:9huet1$i2g$4@nntp.qnx.com

You trying to install it from my site? Install the 6.1 package.

http://staff.qnx.com/~cdm/repository.new/

chris


Benzy Gabay <> bgabay@everbee.com> > wrote:

Hi,

I’m trying to install the gnu bash in the 6.1 ver and it pops up the
following m
essage: “Missing license file for package GNU Bash (bash-2.04-bld2-gnu)”

I have a qnx license, but i have only a paper, no file.

What should i do?

cdm@qnx.com > “The faster I go, the behinder I get.”
Chris McKillop – Lewis Carroll –
Software Engineer, QSSL

Benzy Gabay <bgabay@everbee.com> wrote:

Hi,

I’m trying to install the gnu bash in the 6.1 ver and it pops up the following message: “Missing license file for package GNU Bash (bash-2.04-bld2-gnu)”

I have a qnx license, but i have only a paper, no file.

What should i do?

Look through the manifest file and see if there is a ‘QNXLicenseClass’
tag. If you have a qpr, this is just a tar.gz file containing a qpm and a
qpk. The qpk is the package and the qpm is the manifest. If there is a
license class, then this is most likely a packaging error. The license
class tag tells the package installer that the contents of the qpk are
encrypted and to use the license key associated with that class for
decrypting. GNU bash, of course, should not have a license class since we
only do that sort of thing for certain source distributions like BSPs. If,
that license class is there, you could probably (I think), remove it, repack
the qp[km] into a qpr and try again.

cheers,

Kris


Kris Warkentin
kewarken@qnx.com
(613)591-0836 x9368
“You’re bound to be unhappy if you optimize everything” - Donald Knuth

Well looks like that the *.iso file was corrupted wile d/l it and thats why
i’ve got all those problems !!!

QNX guys:

  1. Can you please put the MD5 checksum on the site?
  2. can you please put in the site a link to an ftp site to the iso/exe
    files, coz looks like the http is not so relyable for large files.

Benz
“Benzy Gabay” <bgabay@everbee.com> wrote in message
news:Voyager.010704094333.52744222A@QNX…

Hi,

I’m trying to install the gnu bash in the 6.1 ver and it pops up the
following message: "Missing license file for package GNU Bash

(bash-2.04-bld2-gnu)"

I have a qnx license, but i have only a paper, no file.

What should i do?

Hi Benzy,

I know this is an old post, but the md5sum and the checksum are
available in the site.
I would like to strongly re-suggest ('cause it has already been
suggested) QSSL to split the iso using a file compressor. It would
really ease the download of the file, since you can safely restart a
broken download (like broken in compressed file #5, you don’t need to
get protions 1, 2, 3 and 4). Additionally, the compressor should has
some sort of CRC checking.

Cheers