Can't get visual age Java runtime to work

I’ve installed the Visual Age package and have edited voyager’s
configuration file to include the lines detailed in
/opt/vane/doc/readme.txt - however, when I point voyager at a java
application link nothing happens.

Ideas please?

Also, how do I read pdf files in QNX6? Well, to be more specific, pdf files
on the hard disk.

thanks

Julian Thornhill

To read pdf’s try using phpdf in the /usr/photon/bin directory.

Poseidon

P.S. Is that a Leicester Uni address?

P.S. Is that a Leicester Uni address?


Yes - any particular reason for the interest?

“Poseidon” <paul.ryan2@nospam.virgin.net> wrote in message
news:9j18bf$g8n$1@nntp.qnx.com

To read pdf’s try using phpdf in the /usr/photon/bin directory.

phpdf is not anywhere on my filesystem. I can’t find it in the repository

either. Am I being dumb here…?

Are you running RtP 6.1, if so, I think that there are other threads in
application and installation which basically say that phpdf doesn’t ship
with 6.1. I don’t know if anyone has found where it is.

As for Leicester, a couple of my mates used to do Maths at the University.

Poseidon

Did you install through the package installer, or did you download from the
http://www.embedded.oti.com web site?

If you installed through the OTI web site, you should make sure that:

  • /opt/vame/ive/bin (or whatever) is on your PATH and LD_LIBRARY_PATH
  • the J9PLUGIN_ARGS variable is set

Note, this needs to be set globally, not just in your .profile or .ksh.
I’ve found it easiest to create a new script in /etc/rc.d called
setj9vars.sh where I ‘set’ these (actually append to the existing PATH and
LD_LIBRARY_PATH). This will get called early enough to be set for the
process that actually runs the VM on behalf of Voyager.

Can’t help for the package installer, since I’ve not played with that.

Patrick_Mueller@oti.com



“Julian Thornhill” <jth@ion.le.ac.uk> wrote in message
news:9j1640$snr$1@inn.qnx.com

I’ve installed the Visual Age package and have edited voyager’s
configuration file to include the lines detailed in
/opt/vane/doc/readme.txt - however, when I point voyager at a java
application link nothing happens.

Ideas please?

Also, how do I read pdf files in QNX6? Well, to be more specific, pdf
files
on the hard disk.

thanks

Julian Thornhill

Patrick Mueller <patrick_mueller@oti.com> wrote in message
news:9j1bp5$ie9$1@nntp.qnx.com

Did you install through the package installer, or did you download from
the
http://www.embedded.oti.com > web site?

If you installed through the OTI web site, you should make sure that:

  • /opt/vame/ive/bin (or whatever) is on your PATH and LD_LIBRARY_PATH
  • the J9PLUGIN_ARGS variable is set

Note, this needs to be set globally, not just in your .profile or .ksh.
I’ve found it easiest to create a new script in /etc/rc.d called
setj9vars.sh where I ‘set’ these (actually append to the existing PATH and
LD_LIBRARY_PATH). This will get called early enough to be set for the
process that actually runs the VM on behalf of Voyager.

Can’t help for the package installer, since I’ve not played with that.

Patrick_Mueller@oti.com

I did it with the package installer. I’ll go through what you said above and

check that nothing is missing. It doesn’t help that there is not a pdf
reader with the qnx 6.1 distribution - makes reading the manuals
difficult…

thanks

Julian Thornhill

Hello,

There is a pdf viewer you could download from the http://quics.qnx.com/cgi-bin/dir_find.cgi?/usr/free site.

Regards,
Dave B.


Poseidon <paul.ryan2@nospam.virgin.net> wrote:

Are you running RtP 6.1, if so, I think that there are other threads in
application and installation which basically say that phpdf doesn’t ship
with 6.1. I don’t know if anyone has found where it is.

As for Leicester, a couple of my mates used to do Maths at the University.

Poseidon

Applications Mail Group <apps@qnx.com> wrote in message
news:9j1d15$ice$3@nntp.qnx.com

Hello,

There is a pdf viewer you could download from the
http://quics.qnx.com/cgi-bin/dir_find.cgi?/usr/free > site.

Regards,
Dave B.


When I do a search on pdf at that URL all I get are 3 responses, all of

which point to QNX4 applications. Am I missing the point somewhere?

I’ve just put a port of xpdf 0.92 at

staff.qnx.com/~cburgess/freestuff

Make sure that you install

libxpm-3.4-x86-public.qpr
t1lib-1.0.1-x86-public.qpr
freetype-1.3.1-x86-public.qpr

and then

xpdf-0.92-x86-public.qpr

Julian Thornhill <jth@ion.le.ac.uk> wrote:

I’ve installed the Visual Age package and have edited voyager’s
configuration file to include the lines detailed in
/opt/vane/doc/readme.txt - however, when I point voyager at a java
application link nothing happens.

Ideas please?

Also, how do I read pdf files in QNX6? Well, to be more specific, pdf files
on the hard disk.

thanks

Julian Thornhill


cburgess@qnx.com

Colin Burgess <cburgess@qnx.com> wrote in message
news:9j1u04$dq$1@nntp.qnx.com

I’ve just put a port of xpdf 0.92 at

staff.qnx.com/~cburgess/freestuff

Make sure that you install

libxpm-3.4-x86-public.qpr
t1lib-1.0.1-x86-public.qpr
freetype-1.3.1-x86-public.qpr

and then

xpdf-0.92-x86-public.qpr


Without wishing to appear too dumb, am I correct in assuming that these

…qpr’s that I have to install are on the web or CD repositry? If not, where
do I find them?

I fear the conversion from the QNX4 mindset is going to long and
painful…

regards

Julian Thornhill

Just go the http://staff.qnx.com/~cburgess/freestuff and click on the
qprs. The package manager will be started automatically.

Julian Thornhill <jth@ion.le.ac.uk> wrote:

Colin Burgess <> cburgess@qnx.com> > wrote in message
news:9j1u04$dq$> 1@nntp.qnx.com> …
I’ve just put a port of xpdf 0.92 at

staff.qnx.com/~cburgess/freestuff

Make sure that you install

libxpm-3.4-x86-public.qpr
t1lib-1.0.1-x86-public.qpr
freetype-1.3.1-x86-public.qpr

and then

xpdf-0.92-x86-public.qpr


Without wishing to appear too dumb, am I correct in assuming that these
.qpr’s that I have to install are on the web or CD repositry? If not, where
do I find them?

I fear the conversion from the QNX4 mindset is going to long and
painful…

regards

Julian Thornhill


cburgess@qnx.com

Colin Burgess <cburgess@qnx.com> wrote:

Just go the > http://staff.qnx.com/~cburgess/freestuff > and click on the
qprs. The package manager will be started automatically.

Oops - just updated the xpdf qpr, changed it to use gzip rather than
uncompress

Julian Thornhill <> jth@ion.le.ac.uk> > wrote:

Colin Burgess <> cburgess@qnx.com> > wrote in message
news:9j1u04$dq$> 1@nntp.qnx.com> …
I’ve just put a port of xpdf 0.92 at

staff.qnx.com/~cburgess/freestuff

Make sure that you install

libxpm-3.4-x86-public.qpr
t1lib-1.0.1-x86-public.qpr
freetype-1.3.1-x86-public.qpr

and then

xpdf-0.92-x86-public.qpr


Without wishing to appear too dumb, am I correct in assuming that these
.qpr’s that I have to install are on the web or CD repositry? If not, where
do I find them?

I fear the conversion from the QNX4 mindset is going to long and
painful…

regards

Julian Thornhill


cburgess@qnx.com


cburgess@qnx.com