network configuration

Greetings,

i tried to establish a network connection by the following way:

phlip configuration: (Devices)
Connection: Manual
IP: 192.168.0.11
Netmask: 255.255.255.0
Device is enabled. :slight_smile:

phlip configuration: (Network)
Host Name: MyQnx
Domain Name: Margarita (name of my local windows/linux workgroup)
Default Gateway: no entry
Name Server: no entry


I edited the file /etc/hosts as follows:
127.1 localhost.localdomain localhost
192.168.0.11 MyWin.Margarita MyWin
192.168.0.33 MyQnx.Margarita MyQnx
I am uncertain about the first line, do i have to change the domain name
from localdomain to Margarita?


I used the following commands to start the network:
slay io-net
io-net -dtulip -ptcpip &

But if i try to ping MyWin i got the message:
No route to host.
I also cant ping to MyQnx from another host.
Thats why i am pretty sure that i forgot something. :slight_smile:

And now i hope you can tell me how to get my tcpip network up and running,
because it’s 1 am and i am tired of RTFM. :slight_smile:

Thanks in advance for any hints,
Mike

Mike wrote:

Greetings,

i tried to establish a network connection by the following way:

I edited the file /etc/hosts as follows:
127.1 localhost.localdomain localhost
192.168.0.11 MyWin.Margarita MyWin
192.168.0.33 MyQnx.Margarita MyQnx
I am uncertain about the first line, do i have to change the domain name
from localdomain to Margarita?

That shouldn’t be nessessary…

I used the following commands to start the network:
slay io-net
io-net -dtulip -ptcpip &

I assume you slayed/restarted io-net before setting up the network in
phlip?

You could check if the NIC has the correct IP set with ifconfig…

I’m not sure, but you might have to set your NIC as the default
gateway…

Mike <just.me@aon.at> wrote:

Greetings,

i tried to establish a network connection by the following way:

phlip configuration: (Devices)
Connection: Manual
IP: 192.168.0.11
Netmask: 255.255.255.0
Device is enabled. > :slight_smile:

phlip configuration: (Network)
Host Name: MyQnx
Domain Name: Margarita (name of my local windows/linux workgroup)
Default Gateway: no entry
Name Server: no entry



I edited the file /etc/hosts as follows:
127.1 localhost.localdomain localhost
192.168.0.11 MyWin.Margarita MyWin
192.168.0.33 MyQnx.Margarita MyQnx
I am uncertain about the first line, do i have to change the domain name
from localdomain to Margarita?



I used the following commands to start the network:
slay io-net
io-net -dtulip -ptcpip &

After restart io-net (you slayed it first, right, do a pidin
make sure no 2 io-net running), you want to do:

netmanager

Also, you probably want to set “look in local hosts file first”
in phlip.

-xtang

But if i try to ping MyWin i got the message:
No route to host.
I also cant ping to MyQnx from another host.
Thats why i am pretty sure that i forgot something. > :slight_smile:

And now i hope you can tell me how to get my tcpip network up and running,
because it’s 1 am and i am tired of RTFM. > :slight_smile:

Thanks in advance for any hints,
Mike

Greetings again,

ifconfig tells me that the NIC is up and running, (IP-Address, Netmask…
looks all right) but i still can’t ping any other host. I tried to set the
IP-Address of the NIC as default Gateway, with the result that ping
complails “Host is down”.(But both hosts are up and the link-led on the hub
is on)

The NIC is a DLink DFE-530TX, and “dipin mem |grep devn” tells me to use the
“tulip” driver, but on the website is written that i should use the driver
“via-rhine”. The problem is, if try to start io-net with the parameter “d
via-rhine” i get an error, telling me “…: No such device”. But the both
drivers (devn-tulip.so, devn-via-rhine.so) are in the directorys
/x86/lib/dll and /lib/dll .
I tried it serval times to load the driver via-rhine but without success. I
also tried to rename the driver and load it but without success.

Now i am uncertain which driver i should use.

Please let me know if you have any ideas,
Mike

Greetings again,

i fixed the problem by exchanging the NIC, everything works fine with a 3Com
3c905C.
This may be a bug, because there was realy no way to load the driver
“via-rhine”.

However,
Thank’s for your support,
Mike


Mike <just.me@aon.at> schrieb in im Newsbeitrag: 9nm5cn$kkv$1@inn.qnx.com

Greetings,

i tried to establish a network connection by the following way:

phlip configuration: (Devices)
Connection: Manual
IP: 192.168.0.11
Netmask: 255.255.255.0
Device is enabled. > :slight_smile:

phlip configuration: (Network)
Host Name: MyQnx
Domain Name: Margarita (name of my local windows/linux workgroup)
Default Gateway: no entry
Name Server: no entry


I edited the file /etc/hosts as follows:
127.1 localhost.localdomain localhost
192.168.0.11 MyWin.Margarita MyWin
192.168.0.33 MyQnx.Margarita MyQnx
I am uncertain about the first line, do i have to change the domain name
from localdomain to Margarita?


I used the following commands to start the network:
slay io-net
io-net -dtulip -ptcpip &

But if i try to ping MyWin i got the message:
No route to host.
I also cant ping to MyQnx from another host.
Thats why i am pretty sure that i forgot something. > :slight_smile:

And now i hope you can tell me how to get my tcpip network up and running,
because it’s 1 am and i am tired of RTFM. > :slight_smile:

Thanks in advance for any hints,
Mike

Mike <just.me@aon.at> wrote:

The NIC is a DLink DFE-530TX, and “dipin mem |grep devn” tells me to use the
“tulip” driver, but on the website is written that i should use the driver
“via-rhine”. The problem is, if try to start io-net with the parameter “d
via-rhine” i get an error, telling me “…: No such device”. But the both
drivers (devn-tulip.so, devn-via-rhine.so) are in the directorys
/x86/lib/dll and /lib/dll .
I tried it serval times to load the driver via-rhine but without success. I
also tried to rename the driver and load it but without success.

The problem with both DLink and Linksys is that they like to change the
chipsets on their cards without changing the version numbers!!! So there
are some 530TX’s that are VIA rhine’s and some that are tulips! Trust
the driver. :wink:

chris

\

cdm@qnx.com > “The faster I go, the behinder I get.”

Chris McKillop – Lewis Carroll –
Software Engineer, QSSL
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<