QNX 6.3.0 Install error

Tried installing QNX on a single HDD with the following layout:

11GB hda1 / MandrakeLinux
10GB hda4 /Solaris 10 install
11GB Free Space
55GB /hda5 /home for Mandrake Linux
512MB /hda6 swap for MandrakeLinux.

So I booted the QNX install CD, it found the free space, asked me since it was greater than 8.4GB what option to use (I used the option for all free space being a newer BIOS), it took all the available space, I did not want a bootloader installed as I have grub, it proceeded to load the drivers and then BAM!! I got an error that read
DINIT: cant open drive /dev/hd0t79
/proc/boot/dinit failed (12292 256).
Thinking I might have made a mistake I rebooted, the installer said a qnx partition existed. But then the install crapped out with the same error.
Now I tried firing up Mandrake but I get a kernel panic. Booted into rescue mode for Mandrake and the installer said I have overlapping paritions!! Note that Solaris on hda4 boots fine.

So my question , is this a bug in QNX or did I goof up somewhere?

Best Regards

Have you tried running from CD & check if the harddisk is able to mount & check using fdisk if all the partitions are there…

QNX’s fdisk is very basic, and may not work if you have many partitions (over 4). You will probably need to use the fdisk from your Linux and do a manual install. Check the discussions below: