firewalls, and the package manager

I’ve gotten voyager to work from behind our firewall, by setting the
proxy server in the connections tab of preferences for voyager. But I
can’t get the package manager to work after doing the same thing in its
preferences. It keeps saying, connection refused.

Scott

More info:

I tried deleting the proxy info that I had put in preferences and then
viewing the QNX WWW Repository. This time, I got the following message,
when I clicked on view errors:

Error while parsing:
/root//.ph.pkg_mgr/repository/entry2/repository.qrm.temp
junk after document element at line 2.

When I looked at the file mentioned in the error, this is what it
contained:

Proxy Authentication Required Enter your Username and/or Password.
If you are using a challenge/response mechanism then just enter your Username

When I repeated the view QNX WWW… request, all the following times, I
just got connection refused. Apparently this is some attempt at querying
for the proxy password, but it doesn’t work. It does work in Voyager.

Scott


“J. Scott Franko” wrote:

I’ve gotten voyager to work from behind our firewall, by setting the
proxy server in the connections tab of preferences for voyager. But I
can’t get the package manager to work after doing the same thing in its
preferences. It keeps saying, connection refused.

Scott

Is this the wrong group for this question?

“J. Scott Franko” wrote:

I’ve gotten voyager to work from behind our firewall, by setting the
proxy server in the connections tab of preferences for voyager. But I
can’t get the package manager to work after doing the same thing in its
preferences. It keeps saying, connection refused.

Scott

Hi,

I think that your proxy could be a NT with Firewall-1 for example, in this
case, it uses the challenge/response (as it’s writen in your log file) to
autentificate you : in fact it tries to get your NT logon/password for
authentification . I’m quite sure that challenge/response would only work
with the browser from Mr Bill Gates (ie Internet Explorer (min release 4, I
think…)). So, as much I know about Voyager, it’s not able to participate
to challenge/response…

I have the same problem at work…
Sorry.

I hope this answers to your questions .

Pete

“J. Scott Franko” a écrit :

Is this the wrong group for this question?

“J. Scott Franko” wrote:

I’ve gotten voyager to work from behind our firewall, by setting the
proxy server in the connections tab of preferences for voyager. But I
can’t get the package manager to work after doing the same thing in its
preferences. It keeps saying, connection refused.

Scott

Actually, it works with voyager. I’m sure it has something to do with NT
Firewalls, because there are two user/passwords I can use, my ppp password for
dialins works through the firewall, and my NT domain username and password
works through the firewall. But in Voyager, only my ppp user/pass works, not
the NT domain user/pass.

But it does work, and there is not challenge/response as with a calculator that
generates the password for you. At least not one that is visible to me as a
user.

But the point is, Voyager works, but pkmgr doesn’t! pkmgr doesn’t even present
me with a login dialog. This question has gone long un-answered from QNX. But
they have been so good at answering my other questions about compile problems
and the like, that I don’t mind. I imagine they will get to it when the this
blizzard from this initial release dies down.

But I imagine that you are very correct in that it might have something to do
with NT. But I would hope that the voyager method of accessing the firewall
could be made into an operating system wide method (say in phlip) that works
with all processes that access the net through firewalls.

Scott

Pierre CAILLIAU wrote:

Hi,

I think that your proxy could be a NT with Firewall-1 for example, in this
case, it uses the challenge/response (as it’s writen in your log file) to
autentificate you : in fact it tries to get your NT logon/password for
authentification . I’m quite sure that challenge/response would only work
with the browser from Mr Bill Gates (ie Internet Explorer (min release 4, I
think…)). So, as much I know about Voyager, it’s not able to participate
to challenge/response…

I have the same problem at work…
Sorry.

I hope this answers to your questions .

Pete

“J. Scott Franko” a écrit :

Is this the wrong group for this question?

“J. Scott Franko” wrote:

I’ve gotten voyager to work from behind our firewall, by setting the
proxy server in the connections tab of preferences for voyager. But I
can’t get the package manager to work after doing the same thing in its
preferences. It keeps saying, connection refused.

Scott

In fact, at job, we’ve got two Firewalls, the standard, this one check you’re
Logon/Password to verify that you’re authorized to go to the Internet and an other
used by some applications that can’t use challenge/response. I have to go through
the second one to access to the QNX package repository on the Net. That’s why I
told you about the problem with NT challenge/response. May be the access to the
repository with pkgmgr use a different port than the HTTP port (80 or 8080). This
other port may be unavailable due to your Firewall. But, I don’t know what could
be this port (if it exists…). You should check it with QNX Support and your
Firewall administrator.

Pete

“J. Scott Franko” a écrit :

Actually, it works with voyager. I’m sure it has something to do with NT
Firewalls, because there are two user/passwords I can use, my ppp password for
dialins works through the firewall, and my NT domain username and password
works through the firewall. But in Voyager, only my ppp user/pass works, not
the NT domain user/pass.

But it does work, and there is not challenge/response as with a calculator that
generates the password for you. At least not one that is visible to me as a
user.

But the point is, Voyager works, but pkmgr doesn’t! pkmgr doesn’t even present
me with a login dialog. This question has gone long un-answered from QNX. But
they have been so good at answering my other questions about compile problems
and the like, that I don’t mind. I imagine they will get to it when the this
blizzard from this initial release dies down.

But I imagine that you are very correct in that it might have something to do
with NT. But I would hope that the voyager method of accessing the firewall
could be made into an operating system wide method (say in phlip) that works
with all processes that access the net through firewalls.

Scott

Pierre CAILLIAU wrote:

Hi,

I think that your proxy could be a NT with Firewall-1 for example, in this
case, it uses the challenge/response (as it’s writen in your log file) to
autentificate you : in fact it tries to get your NT logon/password for
authentification . I’m quite sure that challenge/response would only work
with the browser from Mr Bill Gates (ie Internet Explorer (min release 4, I
think…)). So, as much I know about Voyager, it’s not able to participate
to challenge/response…

I have the same problem at work…
Sorry.

I hope this answers to your questions .

Pete

“J. Scott Franko” a écrit :

Is this the wrong group for this question?

“J. Scott Franko” wrote:

I’ve gotten voyager to work from behind our firewall, by setting the
proxy server in the connections tab of preferences for voyager. But I
can’t get the package manager to work after doing the same thing in its
preferences. It keeps saying, connection refused.

Scott

We were having the same problem here. We’ve got Voyager set up to work with a
SOCKS proxy server, but the package mangler gave us the “connection refused”
response. We changed the proxy server for the mangler to an HTTP proxy server,
and everything now works wonderfully. Hope this helps you as well.

-Warren


“J. Scott Franko” <jsfranko@switch.com> wrote in message
news:39D49160.BF9A2FDA@switch.com
| I’ve gotten voyager to work from behind our firewall, by setting the
| proxy server in the connections tab of preferences for voyager. But I
| can’t get the package manager to work after doing the same thing in its
| preferences. It keeps saying, connection refused.
|
| Scott
|