Old problem, still need help

Hi
I had posted a while back about how after installing the RTP, I can’t boot
into it. I have tried the download executable, the ISO image, and a CD that
was sent to my friend (I hijacked it :slight_smile: ).

The installation goes fine, makes the file, and reboots the computer. I
select QNX RTP from the menu, and it started to load. It mentions that it
can’t find the base config file, and shows an error. A little while later,
it attempts to load the sysinit file, but it stops there.

I’ve changed the drive that I installed it to, even made a small partition
at the beginning of a drive. I installed it there to see if the 1024
cylinder problem was causing the problems, but it didn’t appear to be the
problem.

Any ideas as to how to get it working? Someone had replied that I use the
debug shells, but I don’t know what commands to use (if they are normal
commands like ‘ls’ and ‘cd’ they don’t work).

TIA!

Ron

Try to disable DMA support.

R B Adler <no@mail.com> wrote:

Hi
I had posted a while back about how after installing the RTP, I can’t boot
into it. I have tried the download executable, the ISO image, and a CD that
was sent to my friend (I hijacked it > :slight_smile: > ).

The installation goes fine, makes the file, and reboots the computer. I
select QNX RTP from the menu, and it started to load. It mentions that it
can’t find the base config file, and shows an error. A little while later,
it attempts to load the sysinit file, but it stops there.

I’ve changed the drive that I installed it to, even made a small partition
at the beginning of a drive. I installed it there to see if the 1024
cylinder problem was causing the problems, but it didn’t appear to be the
problem.

Any ideas as to how to get it working? Someone had replied that I use the
debug shells, but I don’t know what commands to use (if they are normal
commands like ‘ls’ and ‘cd’ they don’t work).

TIA!

Ron

Marcin Dzieciol
Technical Support
QNX Software Systems Ltd.
Email: <marcind@qnx.com>

Yeah, I tried that, still gives me the same error. It has me wondering, is
my setup weird or something?

I have 2 SCSI hard drives (using an Adaptec 2940UW) and 2 Ultra DMA66 drives
(on a UDMA controller, some HPT model).
My SCSI drives are my primary drives (“c” and “d”) and the other two are
secondary (“e” and “f”)

I’ve tried installing the QNX RTP to each drive, with the same problem. I
even made a small partition at the beginning of one of them to make sure the
1024 cylinder problem wasn’t causing this issue.

The funny thing is that when I tried the beta of the QNX RTP, it installed
and ran fine. It was actually the easiest installation of ANY version of
QNX that I have had the opportunity to use.

Any other ideas?

TX!
R B Adler


“Marcin Dzieciol” <marcind@qnx.com> wrote in message
news:8t3v59$f6e$2@nntp.qnx.com

Try to disable DMA support.

R B Adler <> no@mail.com> > wrote:
Hi
I had posted a while back about how after installing the RTP, I can’t
boot
into it. I have tried the download executable, the ISO image, and a CD
that
was sent to my friend (I hijacked it > :slight_smile: > ).

The installation goes fine, makes the file, and reboots the computer. I
select QNX RTP from the menu, and it started to load. It mentions that
it
can’t find the base config file, and shows an error. A little while
later,
it attempts to load the sysinit file, but it stops there.

I’ve changed the drive that I installed it to, even made a small
partition
at the beginning of a drive. I installed it there to see if the 1024
cylinder problem was causing the problems, but it didn’t appear to be
the
problem.

Any ideas as to how to get it working? Someone had replied that I use
the
debug shells, but I don’t know what commands to use (if they are normal
commands like ‘ls’ and ‘cd’ they don’t work).

TIA!

Ron


\

Marcin Dzieciol
Technical Support
QNX Software Systems Ltd.
Email: > <marcind@qnx.com>

Hi please go to this url and it will answer your questions http://qdn.qnx.com/report/problemlist.txt
Please be patient the patch is coming…

exert from problemlist.txt


Boot problems/Problems with Boot loaders:

Installation to extended partitions fail, installations to non-primary drives
fail. Typically this results in seeing error messages, “Package manager: Can’t open package
qnxbase…”

Solution is to rearrange your file systems Install on a primary
drive and not to any extended partitions. If installing into Windows filesystem,
only FAT and FAT32 are supported, not NTFS.

You may also want to try disabling DMA for the EIDE controller, this can’t be
done when the boot message, “Press space for boot options” appears. This
can prevent some booting problems on some systems.

IDE cards such as the Promise Ultra66 and Ultra33 are not currently
supported…

\


Thanks
Charles Lawrence
QNX Software Systems



Previously, R B Adler wrote in qdn.public.qnxrtp.installation:

  • Yeah, I tried that, still gives me the same error. It has me wondering, is
  • my setup weird or something?
  • I have 2 SCSI hard drives (using an Adaptec 2940UW) and 2 Ultra DMA66 drives
  • (on a UDMA controller, some HPT model).
  • My SCSI drives are my primary drives (“c” and “d”) and the other two are
  • secondary (“e” and “f”)
  • I’ve tried installing the QNX RTP to each drive, with the same problem. I
  • even made a small partition at the beginning of one of them to make sure the
  • 1024 cylinder problem wasn’t causing this issue.
  • The funny thing is that when I tried the beta of the QNX RTP, it installed
  • and ran fine. It was actually the easiest installation of ANY version of
  • QNX that I have had the opportunity to use.
  • Any other ideas?
  • TX!
  • R B Adler
  • “Marcin Dzieciol” <marcind@qnx.com> wrote in message
  • news:8t3v59$f6e$2@nntp.qnx.com
  • Try to disable DMA support.

  • R B Adler <no@mail.com> wrote:

  • Hi

  • I had posted a while back about how after installing the RTP, I can’t

  • boot
  • into it. I have tried the download executable, the ISO image, and a CD

  • that
  • was sent to my friend (I hijacked it :slight_smile: ).

  • The installation goes fine, makes the file, and reboots the computer. I

  • select QNX RTP from the menu, and it started to load. It mentions that

  • it
  • can’t find the base config file, and shows an error. A little while

  • later,
  • it attempts to load the sysinit file, but it stops there.

  • I’ve changed the drive that I installed it to, even made a small

  • partition
  • at the beginning of a drive. I installed it there to see if the 1024

  • cylinder problem was causing the problems, but it didn’t appear to be

  • the
  • problem.

  • Any ideas as to how to get it working? Someone had replied that I use

  • the
  • debug shells, but I don’t know what commands to use (if they are normal

  • commands like ‘ls’ and ‘cd’ they don’t work).

  • TIA!

  • Ron

  • Marcin Dzieciol

  • Technical Support

  • QNX Software Systems Ltd.

  • Email: marcind@qnx.com

Ah, very good!

R B Adler

“Charles Lawrence” <clawrence@qnx.com> wrote in message
news:Voyager.001026110934.22319A@funnel.qnx.com

Hi please go to this url and it will answer your questions
http://qdn.qnx.com/report/problemlist.txt
Please be patient the patch is coming…

exert from problemlist.txt


Boot problems/Problems with Boot loaders:

Installation to extended partitions fail, installations to non-primary
drives
fail. Typically this results in seeing error messages, “Package manager:
Can’t open package
qnxbase…”

Solution is to rearrange your file systems Install on a primary
drive and not to any extended partitions. If installing into Windows
filesystem,
only FAT and FAT32 are supported, not NTFS.

You may also want to try disabling DMA for the EIDE controller, this can’t
be
done when the boot message, “Press space for boot options” appears. This
can prevent some booting problems on some systems.

IDE cards such as the Promise Ultra66 and Ultra33 are not currently
supported…

\


Thanks
Charles Lawrence
QNX Software Systems



Previously, R B Adler wrote in qdn.public.qnxrtp.installation:

  • Yeah, I tried that, still gives me the same error. It has me wondering,
    is
  • my setup weird or something?
  • I have 2 SCSI hard drives (using an Adaptec 2940UW) and 2 Ultra DMA66
    drives
  • (on a UDMA controller, some HPT model).
  • My SCSI drives are my primary drives (“c” and “d”) and the other two are
  • secondary (“e” and “f”)
  • I’ve tried installing the QNX RTP to each drive, with the same problem.
    I
  • even made a small partition at the beginning of one of them to make sure
    the
  • 1024 cylinder problem wasn’t causing this issue.
  • The funny thing is that when I tried the beta of the QNX RTP, it
    installed
  • and ran fine. It was actually the easiest installation of ANY version
    of
  • QNX that I have had the opportunity to use.
  • Any other ideas?
  • TX!
  • R B Adler
  • “Marcin Dzieciol” <> marcind@qnx.com> > wrote in message
  • news:8t3v59$f6e$> 2@nntp.qnx.com> …
  • Try to disable DMA support.

  • R B Adler <> no@mail.com> > wrote:

  • Hi

  • I had posted a while back about how after installing the RTP, I
    can’t

  • boot
  • into it. I have tried the download executable, the ISO image, and a
    CD

  • that
  • was sent to my friend (I hijacked it > :slight_smile: > ).

  • The installation goes fine, makes the file, and reboots the
    computer. I

  • select QNX RTP from the menu, and it started to load. It mentions
    that

  • it
  • can’t find the base config file, and shows an error. A little while

  • later,
  • it attempts to load the sysinit file, but it stops there.

  • I’ve changed the drive that I installed it to, even made a small

  • partition
  • at the beginning of a drive. I installed it there to see if the
    1024

  • cylinder problem was causing the problems, but it didn’t appear to
    be

  • the
  • problem.

  • Any ideas as to how to get it working? Someone had replied that I
    use

  • the
  • debug shells, but I don’t know what commands to use (if they are
    normal

  • commands like ‘ls’ and ‘cd’ they don’t work).

  • TIA!

  • Ron

  • Marcin Dzieciol

  • Technical Support

  • QNX Software Systems Ltd.

  • Email: > marcind@qnx.com